Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

site defaults to page not found via check-php


Go to End
Reply

10 Posts   4841 Views

Avatar
StillLearning

2 January 2009 at 3:34pm (Last edited: 2 January 2009 6:24pm), Community Member, 12 Posts

Hi, Silverstrip looks great and has installed fine but when I access the site it defaults to the page not found page via http://www.xxxxxx.com/check-php.php.

I though/think i have deleted the install files but..... duh maybe not?
What am i missing. i cannot see check-php anywhere!

......now after deleting the page that it was defaulting to on load I get: [The requested page couldn't be found.] however, if I go to http://www.name of my site .com/index/ manually it all looks fine. Very wierd.

Obviously something .... an index file is pointing to the (now missing) page on first load but i cannot find where this is!

Avatar
dttri

2 January 2009 at 5:56pm Community Member, 5 Posts

Look like your problem is the same as mine:

http://www.silverstripe.org/installing-silverstripe/show/251479

Avatar
StillLearning

2 January 2009 at 5:58pm Community Member, 12 Posts

Yes I think so. i just can't figure out why. I have checked everything that I can think of and flushed (and washed my hands)....:-)

Avatar
Tobbe

3 January 2009 at 1:57am (Last edited: 3 January 2009 1:58am), Community Member, 25 Posts

Have you added the domain (xxxxxx.com) to the "Use this page as the 'home page' for the following domains: (separate multiple domains with commas)"-field in the Behavior tab?
I think I had about the same behavoiur before, when I deleted the default home page and not added the domain to this field.

Avatar
StillLearning

7 January 2009 at 12:29pm Community Member, 12 Posts

You know that might be in Tobbe, thank you ... but there are two more steps required to make it work I think. 1. Flush (append /db/build?flush=1 to the end of your URL) and 2. Reset (flush) cookies in your broswer (I reset Safari)..... then all seems normal.

Thank you for the tip. :-)

Avatar
Liam

8 January 2009 at 10:28am Community Member, 470 Posts

Ya it's a caching issue. I've found just restarting the browser does the trick.

Avatar
Sigurd

8 January 2009 at 1:03pm Forum Moderator, 628 Posts

This is mentioned at this (now fixed) bug report - http://open.silverstripe.com/ticket/2196

Can you let us know if SS 2.3rc2 no longer contains this fault? :)

Avatar
StillLearning

8 January 2009 at 1:27pm Community Member, 12 Posts

Actually I was using SS 2.2.3 which i thought was the latest stable release as i only downloaded it a few days ago. Using that release on three simple sites i did experience the issue but was able to resolve it via the above process. i suspect it has as much to do with Safari cahing as anything else .... it was only after posting that i tried flushing/resetting Safari and have not tried *only* resetting without dong the other things..... so that makes my conclusion inconclusive if you know what i mean. :-)

PS. Thanks to the SS team for a really great CMS i am so happy with it! Discovering SS was a great start to 2009!

Go to Top