Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

A trouble with write permissions


Go to End
Reply


12 Posts   3100 Views

Avatar
Kasutajanimi

Community Member, 15 Posts

8 January 2009 at 4:46am

Hello!
I need a help with one problem, appeared in installation process of SilverStripe CMS v2.2.3 on my local machine.
There are some critical issues (troubles, marked by orange), wich are represented on screenshot:
[url=http://i43.tinypic.com/2m3ie60.jpg][/url]
(click to see full size image)

The configuration of my localhost server is also represented on screenshot.

I wait for your help.

Attached Files
Avatar
Tobbe

Community Member, 25 Posts

8 January 2009 at 5:31am

I don't remember I had this errors, when installing on Windows Vista. But I guess you might have forgotten to give the user all permissions to the folders in your screenshot. See this on the Vista-chapter.
http://doc.silverstripe.com/doku.php?id=installation-on-windows

If you are installing on earlier version of Windows than Vista, you could probably just continue installation as I think the webserver will be able to save files in those folders anyway.

Avatar
Sigurd

Forum Moderator, 628 Posts

8 January 2009 at 9:04am

You might wish to create an empty file called .htaccess that is able to be written to by the Apache program, and then reload the install page you showed. Let us know if that works. Please confirm that if you do click 'install' that it fails, as well...

Avatar
Kasutajanimi

Community Member, 15 Posts

8 January 2009 at 9:59am

If you are installing on earlier version of Windows than Vista, you could probably just continue installation as I think the webserver will be able to save files in those folders anyway.
I already try it, but installation crashes this way :(
I have Windows XP Home Edition SP2.

.htaccess file already exist and have zero size, but it don't consider the problem.
I shall try to RTFM by upper URL, but I need more concrete solutions.

Avatar
Sigurd

Forum Moderator, 628 Posts

8 January 2009 at 10:01am

Ok, then you certainly need to change the permission of those files. Find them in explorer, right click them, and change the permission. If you are not sure of the specific permission to allow, you could perhaps to 'writable by any user'? This is only suggested for a machine where you are not doing web-hosting from, as it may allow people to compromise your website.

Avatar
Kasutajanimi

Community Member, 15 Posts

8 January 2009 at 10:23am

Edited: 08/01/2009 10:36am

There are no group polices in Home Edition
And there are no atributes on this files and folders such as 'hidden', 'read only', 'archive' and 'system'.

If I continue installation process not looking at the issues, I take this errors (look at screenshot).
If I press continue again, my server says about 500th erorr.

Attached Files
Avatar
Sigurd

Forum Moderator, 628 Posts

8 January 2009 at 12:56pm

That error is actually a mod_rewrite error rather than a file permission error.

Are you sure that mod_rewrite is enabled on your server? (It may be, but just curious).

Avatar
Sam

Administrator, 685 Posts

8 January 2009 at 2:04pm

Hi Kasutajanimi,

We have made a number of improvements to this stuff in 2.3; you might want to try installing 2.3.
http://www.silverstripe.org/release-candidate/

Go to Top