Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Another .htaccess problem


Reply

4 Posts   1324 Views

Avatar
StarCrescent

30 January 2009 at 11:27am Community Member, 4 Posts

I am trying to install SS to LAMP server all the requirements checks OK .htaccess w/r requirements are OK as well. When I hit the install button I get the following.

Installing SilverStripe...

I am now running through the installation steps (this should take about 30 seconds)

If you receive a fatal error, refresh this page to continue the installation
# Creating 'mysite/_config.php'...
# Creating /usr/hosts/domains/herekezeki/www.herekezeki.com/httpdocs/mysite/_config.php
# Creating '.htaccess' file...
# Creating /usr/hosts/domains/herekezeki/www.herekezeki.com/httpdocs/.htaccess
# Building database schema...

and it stalls.

When I reload the page or any other page I get 500 Internal Server Error.

My .htaccess file after the trial is:

## SILVERSTRIPE START ###
<IfModule mod_dir.c>
DirectorySlash Off
</IfModule>

RewriteEngine On
RewriteBase /

RewriteCond %{REQUEST_URI} !(\.gif)|(\.jpg)|(\.png)|(\.css)|(\.js)|(\.php)$

RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]
### SILVERSTRIPE END ###

when I remove the .htaccess it goes to install page again with "User 'herekezeki' needs to be able to write to this file:
/usr/hosts/domains/herekezeki/www.herekezeki.com/httpdocs/.htaccess" warning, naturally.

What is wrong. I couldn't figured it out. Any help is greatly appriciated.

Avatar
Willr

30 January 2009 at 12:03pm Forum Moderator, 5511 Posts

500 Internal Server Error - have you looked in the server logs? (usually in /var/logs/ or if you have cpanel they have a section for them) they might provide a clue as to the problem

Avatar
StarCrescent

30 January 2009 at 9:27pm (Last edited: 30 January 2009 9:30pm), Community Member, 4 Posts

I am on a rented web hosting space and have no way to check the logs. Support says its a .htaccess problem.

Avatar
StarCrescent

31 January 2009 at 11:28pm (Last edited: 1 February 2009 12:54am), Community Member, 4 Posts

This is not going to work.