Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Using Wordpress on a Silverstripe Subdomain


Reply


13 Posts   5026 Views

Avatar
Nivanka

Community Member, 395 Posts

14 May 2009 at 10:33pm

AdamMWMM, what is the problem you are having with the blog module, I dont think it will be a good solution to install wordpress as the SS blog module is not working, because you will have two backends for your website, and quite messy. Have you posted anything on the forum about the issues you are experiencing with the blog module?

Avatar
AdamMWMM

Community Member, 12 Posts

19 May 2009 at 4:42am

I have tried posting here about my issues with the SS blog. I just didn't get any response so I had to come up with my own solution so I could meet my deadline.

Here's my original post about the SS Blog:
http://silverstripe.org/blog-module-forum/show/260163#post260163

Avatar
marblegravy

Community Member, 19 Posts

13 April 2010 at 8:21pm

Adam! Thankyou or posting the answer here!
I can confirm that adding:

RewriteCond %{REQUEST_URI} !/blog


worked and allowed Wordpress to install happily on a server already running silverstripe!

You have saved my week!

Avatar
pcknights2

Community Member, 4 Posts

12 September 2014 at 11:16pm

Hello
I need HEEEELPP please someone
I have a silverstripe site and i have created a blog folder and inside i moved my wordpress
in my root folder .htaccess i have:

### SILVERSTRIPE START ###
<Files *.ss>
   Order deny,allow
   Deny from all
   Allow from 127.0.0.1
</Files>

<Files web.config>
   Order deny,allow
   Deny from all
</Files>

ErrorDocument 404 /assets/error-404.html
ErrorDocument 500 /assets/error-500.html

<IfModule mod_alias.c>

   RedirectMatch 403 /silverstripe-cache(/|$)
   
   
</IfModule>

<IfModule mod_rewrite.c>
   SetEnv HTTP_MOD_REWRITE On
   RewriteEngine On
   
   # Canonicalization
   RewriteCond %{HTTP_HOST} !^www\.3x1\.com
   RewriteRule (.*) http://www.3x1.com/$1 [R=permanent,L]

   RewriteCond %{REQUEST_URI} ^(.*)$
   RewriteCond %{REQUEST_FILENAME} !-f
   RewriteRule .* sapphire/main.php?url=%1 [QSA]

   RewriteCond %{REQUEST_URI} ^(.*)/sapphire/main.php$
   RewriteCond %{REQUEST_FILENAME} !-f
   RewriteRule . %1/install.php? [R,L]

   RewriteCond %{REQUEST_URI} !/blog*
   RewriteCond %{REQUEST_URI} !/blog

</IfModule>

RewriteCond %{REQUEST_URI} !/blog*
RewriteCond %{REQUEST_URI} !/blog
### SILVERSTRIPE END ###

I have added the 4 lines
RewriteCond %{REQUEST_URI} !/blog*
RewriteCond %{REQUEST_URI} !/blog
After reading previous posts but this didnt help
when i am trying to access www.sitename/blog and also www.sitename/blog/index.php it redirects to www.sitename/blog and I get
'Sorry, it seems you were trying to access a page that doesn't exist.'
Please someone help!

Avatar
pcknights2

Community Member, 4 Posts

16 September 2014 at 1:50am

Edited: 16/09/2014 6:07pm

The website is hosted in IIS and someone told me that IIS uses web.config instead of .htaccess
bellow is the code for web.config in the root folder
<?xml version="1.0" encoding="UTF-8"?>
<configuration>
<system.webServer>
<defaultDocument>
<files>
<clear />
<add value="index.php" />
<add value="Default.htm" />
<add value="Default.asp" />
<add value="index.htm" />
<add value="index.html" />
<add value="iisstart.htm" />
<add value="default.aspx" />
</files>
</defaultDocument>
<rewrite>
<rules>
<clear />
<rule name="RequestBlockingRule1" patternSyntax="Wildcard" stopProcessing="true">
<match url="*" />
<conditions logicalGrouping="MatchAll">
<add input="{REMOTE_ADDR}" negate="true" pattern="127.0.0.1" />
<add input="{URL}" pattern="*.ss" />
</conditions>
<action type="CustomResponse" statusCode="403" />
</rule>
<rule name="SilverStripe Clean URLs" stopProcessing="true">
<match url="^(.*)$" />
<conditions logicalGrouping="MatchAll">
<add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true" />
</conditions>
<action type="Rewrite" url="sapphire/main.php?url={R:1}" appendQueryString="true" />
</rule>
</rules>
</rewrite>
<directoryBrowse enabled="false" />
</system.webServer>
</configuration>