Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Where can I find php.ini


Go to End
Reply


10 Posts   5114 Views

Avatar
JSD1985

Community Member, 12 Posts

6 February 2009 at 10:34pm

Hello everyone,

I want to install silverstripe, everything is correct, except I get this message:

allow_call_time_pass_reference is set to '' in php.ini. You can install with allow_call_time_pass_reference not set, but some warnings may get displayed. For best results, turn it on.

where can I find php.ini?

I looked in the root but it wasn't there and also not in the unzipped files.

Greetz,
Jeroen

Avatar
Carbon Crayon

Community Member, 598 Posts

7 February 2009 at 12:18am

Your php.ini is usually set by your host but you can create one and overide theirs, are you using an online host or is it setup locally on your own machine?

Avatar
JSD1985

Community Member, 12 Posts

7 February 2009 at 1:23am

I use a online host but I can't find php.ini anywhere on the server. if i create php.ini myself, where should I place it on the server? in the root of my silverstripe directory? Can you put the code of php.ini in a reply or something? Tnx!

Avatar
Carbon Crayon

Community Member, 598 Posts

7 February 2009 at 3:04am

ok try this, create a php.ini in your root directory and put this in it:

allow_call_time_pass_reference = on

Then in your .htaccess add this line to the top:

SuPHP_ConfigPath /[your]/[path]/php.ini

where /[you]/[path]/ is the path from your server's root to your new php.ini file. For example one of mine is /home/aabmsl/public_html/php.ini

Bear in mind that that will mean all your php settings are run at default except for the ones you set in you new php.ini, but they are probably running at default anyway if you dont already have a php.ini

For calrification on that Contact your host.

Avatar
JSD1985

Community Member, 12 Posts

7 February 2009 at 4:12am

Ok,

I now have a file called php.ini with this code in it:

<?PHP

allow_call_time_pass_reference = on;

?>

And i have a file named .htaccess

SuPHP_ConfigPath /php.ini

Both files are in the root of my silverstripe folder but now i get this when I want to install silverstripe:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator to inform of the time the error occurred and of anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Web Server at jsdstudios.nl

What can I do about this and what is wrong with php.ini or .htaccess?

Greetz,
Jeroen

Avatar
Carbon Crayon

Community Member, 598 Posts

7 February 2009 at 4:18am

Edited: 07/02/2009 4:19am

hmm, well firstly your php.ini file sould not have <?php tags in it, and the line in your .htaccess needs to have the full server path in it, for example /home/username/public_html/php.ini

I think your best bet at this point is to contact your host and get them to sort it out for you.

Avatar
JSD1985

Community Member, 12 Posts

7 February 2009 at 4:18am

When I remove .htaccess from my server the installation wizard starts perfectly, but it keeps saying the php.ini error. Something is wrong with .htaccess but I don't know what.

Avatar
Carbon Crayon

Community Member, 598 Posts

7 February 2009 at 4:20am

have you actually tried just installing SS and seeing what happens? It's only a warning so it should be fine.

Go to Top