Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Installation errors


Go to End
Reply


13 Posts   2883 Views

Avatar
JSD1985

Community Member, 12 Posts

9 February 2009 at 6:02am

Hello,

When I want to install silverstripe i get this message:

mod_rewrite doesn't appear to be working. Make sure:

* mod_rewrite is enabled in your httpd.conf
* AllowOverride is enabled for the current path.

What can I do about this? I also can't find the httpd.conf file.

Greetz,
Jeroen

Avatar
Willr

Forum Moderator, 5513 Posts

9 February 2009 at 9:24am

What type of server are you trying to setup - like on your computer or a webserver?. If you are on the linux host the httpd.conf file is usually in /etc/apache2/. You will need to make sure AllowOverride is on in that (if you can't access or edit that file you will need to talk to your host)

Avatar
JSD1985

Community Member, 12 Posts

9 February 2009 at 11:23am

I use a webhosting service by a extern company so it's on a webserver. I have no idea if they use Linux or Windows servers. I think the use Linux.

So I need to contact my webhoster? I find it kinda strange because I did more SilverStripe installations before and everything worked fine. Maybe it has to do with a SS update or something.

Greetz,
Jeroen

Avatar
d-virus

Community Member, 21 Posts

15 March 2009 at 2:26pm

in your htacces file, add this lines

AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php

Avatar
pace obed

Community Member, 6 Posts

18 March 2009 at 5:18am

I have same problem with JSD1985. I want install SS on my computer, I get this message :

mod_rewrite enabled   You need mod_rewrite to run SilverStripe CMS, but it is not enabled.

what is the solution for my problem?

regadrs,
obed

Avatar
d-virus

Community Member, 21 Posts

18 March 2009 at 5:24am

Hey pace obed, open your htacces and put the lines:

AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php

save your htacces, and try again.

Avatar
pace obed

Community Member, 6 Posts

18 March 2009 at 5:31am

Edited: 18/03/2009 5:32am

@d-virus, I have add your script like this :
### SILVERSTRIPE START ###
<Files *.ss>
Order deny,allow
Deny from all
Allow from 127.0.0.1
</Files>

<IfModule mod_rewrite.c>
RewriteEngine On
AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php
RewriteCond %{REQUEST_URI} !(\.gif)|(\.jpg)|(\.png)|(\.css)|(\.js)|(\.php)$

RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]
</IfModule>
### SILVERSTRIPE END ###

but still error. any idea?

Avatar
d-virus

Community Member, 21 Posts

18 March 2009 at 5:34am

Please put the lines before silverstripe start:

AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php
### SILVERSTRIPE START ###
<Files *.ss>
Order deny,allow
Deny from all
Allow from 127.0.0.1
</Files>

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{REQUEST_URI} !(\.gif)|(\.jpg)|(\.png)|(\.css)|(\.js)|(\.php)$

RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]
</IfModule>
### SILVERSTRIPE END ###

Go to Top