Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

How do I enable mod-rewrite


Reply

4 Posts   3824 Views

Avatar
Nirkoso

10 February 2009 at 11:32pm Community Member, 3 Posts

Hi guys im novice at all of this, I've installed wamp on my comp. (win user) and when i've executed install.html (which leads to install.php) i get "You aren't currently able to install the software"
and in red in the bottom of the screen i get "You need mod_rewrite to run SilverStripe CMS, but it is not enabled."

how do i do it????

all help well appretiated

thanks

Nir

Avatar
Toffy

11 February 2009 at 1:21am Community Member, 2 Posts

Hi !

open your .htaccess File at Filesystem root
Add the word:

ReWriteEngine On

Toffy

Avatar
Nirkoso

12 February 2009 at 12:40am Community Member, 3 Posts

Hi toffy

thanks for the quick respond,
i've opened the .htaccess in the file root (Im not sure but i guess it means the specific site file root)
the .htaccess was empty,
so i added the line

but now even the index.html wont work, i keep getting this mistake:

"Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, admin@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log."

arrrrrgghhh

??

Avatar
Nirkoso

12 February 2009 at 1:05am Community Member, 3 Posts

o.k

for u other guys like me
there is some step to be done before the .htaccess

Enable mod_rewrite

1. Find the httpd.conf file (usually you will find it in a folder called conf, config or something along those lines)
2. Inside the httpd.conf file uncomment the line LoadModule rewrite_module modules/mod_rewrite.so (remove the pound '#' sign from in front of the line)
3. Also find the line ClearModuleList is uncommented then find and make sure that the line AddModule mod_rewrite.c is not commented out.

(i couldnt find the lines in step 3 i guess its for an older version) but it seems to works

have fun!