Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

IIS 7 on Windows 2008 server install problems.


Reply

11 Posts   5442 Views

Avatar
dynamite

4 March 2009 at 10:28am Community Member, 66 Posts

@Sigurd: here is how my SS install on IIS 7 has progressed so far. I followed the steps from the documentation, and copied the web.config verbatim.

Received the following error:

PHP Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(../../_ss_environment.php) is not within the allowed path(s): (C:\inetpub\wwwroot) in C:\inetpub\wwwroot\sapphire\core\Core.php on line 31 PHP Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(../../../_ss_environment.php) is not within the allowed path(s): (C:\inetpub\wwwroot) in C:\inetpub\wwwroot\sapphire\core\Core.php on line 31 PHP Fatal error: Permission problem gaining access to a temp folder. Please create a folder named silverstripe-cache in the base folder of the installation and ensure it has the correct permissions in C:\inetpub\wwwroot\sapphire\core\Core.php on line 230

I tried creating the folder "silverstripe-cache" and refreshed, but get a looong list of files it cannot open with the error "Permission Denied"

So, I opened php.ini and "commented out" the "open_basedir" line, restarted IIS, **and** deleted the "silverstripe-cache" folder.

Now I get the SS install screen.

According to the documentation at http://doc.silverstripe.com/doku.php?id=iis-installation I am suppose to delete the .htaccess file before loading up http://localhost//install.php but if you do that, the SS complains that the .htaccess file is not writable. So I am leaving it in place until after the install.

Enter the MySQL details, admin account, everything looks good except for "warnings" about "allow_call_time_pass_reference" and not being able to tell if mod_rewrite is running.

Click on Install and get the "generic" Windows 500 Internal Server Error.

An interesting side note (maybe a good clue, actually), is when I try and load it from a different computer via the public IP address, it tries to re-direct with a backslash included. E.g., http://192.168.168.168 tried to send me to http://192.168.168.168\/install.php and the browser complains about a bad address.

I am going to try a "manual" install.

Thanks again for the assistance everyone!

Avatar
dynamite

4 March 2009 at 11:33am Community Member, 66 Posts

I did "manual" install (moved the database tables over from my development server, and set up my _config.php), and that all worked great... except, I think I may have found the source of my problems doing the install: my IIS_IUSRS didn't have "modify" or "write" permission on the "wwwroot" folder.

Did I miss that note somewhere? It is brand-new install, with updates, of MS Windows Server 2008, Standard Edition.

Thanks all, and maybe someone else will find this helpful!

Avatar
Sigurd

6 March 2009 at 2:42pm Forum Moderator, 628 Posts

There is an update at http://silverstripe.org/installing-silverstripe/show/255574?showPost=255574