Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Errors installing RC3 - Linux, Apache


Go to End
Reply


13 Posts   4610 Views

Avatar
fishe

Community Member, 42 Posts

14 February 2009 at 11:23am

I get the following error after the initial install page. Everything is green on that page except for the final two warnings about not being able to detect web server...but I've never seen those green :)

I am now running through the installation steps (this should take about 30 seconds)

If you receive a fatal error, refresh this page to continue the installation

* Creating 'mysite/_config.php'...
* Creating /home/robynmat/public_html/ss/mysite/_config.php
* Creating '.htaccess' file...
* Creating /home/robynmat/public_html/ss/.htaccess

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /home/robynmat/public_html/ss/sapphire/core/ManifestBuilder.php on line 391

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /home/robynmat/public_html/ss/sapphire/core/ManifestBuilder.php on line 391

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /home/robynmat/public_html/ss/sapphire/core/ManifestBuilder.php on line 391

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /home/robynmat/public_html/ss/sapphire/core/ManifestBuilder.php on line 391

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /home/robynmat/public_html/ss/sapphire/core/ManifestBuilder.php on line 391

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /home/robynmat/public_html/ss/sapphire/core/ManifestBuilder.php on line 391

* Building database schema...

Parse error: syntax error, unexpected $end in /home/robynmat/public_html/ss/mysite/code/Page.php on line 55

Avatar
fishe

Community Member, 42 Posts

14 February 2009 at 11:31am

After this the installation isn't finished - nothing is created in the database...

Any ideas guys? Thanks.

Avatar
fishe

Community Member, 42 Posts

15 February 2009 at 10:46am

Another weird thing is that the title bar of the web page displays "PHP 5 is required"

However PHP Version 5.2.4 is installed.

Avatar
Tim

Core Development Team, 201 Posts

16 February 2009 at 1:11pm

Added a bug report for this

http://open.silverstripe.org/ticket/3554

Avatar
fishe

Community Member, 42 Posts

21 February 2009 at 12:11pm

I see the bug report has been updated but I don't understand the update...

Changed 4 days ago by ischommer ¶

* status changed from new to closed
* resolution set to worksforme

This is an error in custom code (Page.php), most likely not a core problem.
------------

So what's the implication here? This issue is resolved in the latest nightly build? What does "resolution set to worksforme" mean?

Thanks.

Avatar
fishe

Community Member, 42 Posts

23 February 2009 at 5:48pm

I still get this error with the 2.3.0 final build.

For some other possibly useful details:

1. I'm installing to a subdirectory "ss"

2. In the installation process I get an error about .htaccess:
--------------
User 'robynmat' needs to be able to write to this file:
/home/robynmat/public_html/ss/.htaccess

The file is currently owned by 'root'. There is no user-group that contains both the web-server user and the owner of this file. Change the ownership of the file, create a new group, or temporarily make the file writeable by everyone during the install process.
-------------

But I can sort this by creating an empty .htaccess file through SSH (touch .htaccess) in the "ss" directory...that stops the error.

Any other ideas guys? This is a really frustrating weird issue I can't seem to get around. And changing hosts would be a problem - plus it is on Nucleus which, I'm told, should support SS fine. Doesn't SilverStripe the company use it for hosting their projects?

Avatar
fishe

Community Member, 42 Posts

26 February 2009 at 6:51pm

Resolved!

Tracked it down to an issue with php.ini on the host:

register_argc_argv wasn't being picked up as 'on' (it was written like - register_argc_argv= On). After adding a tab/space between register_argc_argv and = things started working.

Hopefully this can help some other people as something to check - random issue though.

Avatar
Yulia

Community Member, 26 Posts

10 March 2009 at 1:25am

Edited: 10/03/2009 2:23am

I got the same problem. It went through the installation with the same error and it occurs on a top of a browser. Sometimes it does, sometimes it does not. I don't see to have an access to the php.ini file, so i contacted my host server and asked them to resolve it in which they responded: As we are not able to troubleshoot or support custom coding, I recommend you contact your software vendor or a software developer regarding the issue you are experiencing. I am stuck with network solutions and they suck!

I know it might sound a bit naive...
I am not quite sure what to do, is there a way to fix it other way?
like creating custom php.ini file somehow?

thanks a lot!

Go to Top