Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Testers Required - SecureFiles 0.1.1 Module


Reply

27 Posts   5525 Views

Avatar
Hamish

13 November 2009 at 4:35pm (Last edited: 4 March 2010 1:40pm), Community Member, 712 Posts

Haven't tested with 2.4.

SilverStripe Ltd appear to have put it into their [url=http://svn.silverstripe.com/open/modules/securefiles/trunk/]repository[/url] and modified it to use group settings as many people have requested. I'm now submitting patches against their version (see a list [url=http://open.silverstripe.org/query?component=Modules+-+securefiles&col=id&col=summary&col=status&col=type&col=priority&col=milestone&col=component&order=priority]here[/url]).

By the way, it would've been nice to get an email or something. I started implementing group permissions a few weekends ago in my version, only to find out (by chance) that it had been taken in house. </gripe>

Avatar
x75

17 November 2009 at 3:15am (Last edited: 4 March 2010 1:40pm), Community Member, 42 Posts

Hi,

i just downloaded the module from svn. Unfortunatly there is still a problem if you use it to secure this images of an image-gallery.

Once you secure the images, the thumbnails stop working. Instead you get the images in their original size. I asked UncleCheese if he could do anything abaout it. [url=http://www.silverstripe.org/dataobjectmanager-module-forum/show/270972?start=0#post270979](here)[/url] But he thinks it not a problem of his image-gallery module.
Do you have any idea what i could do to fix this?

Thanks
Johannes

Avatar
Hamish

17 November 2009 at 8:40am (Last edited: 4 March 2010 1:40pm), Community Member, 712 Posts

I believe that this fixes it:

[url]http://open.silverstripe.org/ticket/4649[/url]

Avatar
x75

17 November 2009 at 12:14pm (Last edited: 4 March 2010 1:40pm), Community Member, 42 Posts

Hi,
thanks for your fast reply!
I implementet that patch, but it does not help. As soon as I secure a folder, the gallery breaks when I reload the page.

Any other idea?

Thanks
Johannes

Avatar
ImacSS

8 December 2009 at 5:34am (Last edited: 4 March 2010 1:40pm), Community Member, 35 Posts

Hey Hamish,

Great idea for a module. Appreciate the work you've put into this so far.

Just an FYI - I downloaded the latest trunk (svn-trunk-r5.tar.gz) and it appears to contain a minor typo in SecureFileController.php on line 23 - missing the closing quotation.

Really like the addition of the group assignment - just what I need for this current project.

Thanks again.

Avatar
Juanitou

2 March 2010 at 6:32am (Last edited: 4 March 2010 1:40pm), Community Member, 323 Posts

Hi Hamish!

I’m not tested the module yet, but I’d like to humbly contribute by providing French and Spanish translations. I have a doubt: where should I submit them, to the SS or to the Polemic Trac? By the way, what repository should be check with SVN?

Best regards,
Juan

Avatar
Hamish

2 March 2010 at 8:55am (Last edited: 4 March 2010 1:40pm), Community Member, 712 Posts

Hey, thanks! Translations would be awesome.

I have a doubt: where should I submit them, to the SS or to the Polemic Trac?

I'm (trying to) actively maintain the one at [url]http://polemic.net.nz/trac/[/url]. I've been very busy and there are some known bugs I need to squash, and I need to make sure the required translatable sections exist, but that is where I would prefer patches are submitted.

The version at http://open.silverstripe.org/ was imported by SilverStripe for their own uses. I don't have any control over what happens in their repo, so you can submit there too if you want but I can't say when/if they'll be committed.

Avatar
Juanitou

3 March 2010 at 10:38am (Last edited: 4 March 2010 1:40pm), Community Member, 323 Posts

OK. Translations are already done (takes less than five minutes), but I’ll submit there when I will find some time to install and check the module, as context is lacking. By the way, I’ve not found where the VIEW string goes in the code files…