Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

PHP 5 is required


Go to End
Reply


26 Posts   7276 Views

Avatar
JZM

Community Member, 34 Posts

28 February 2009 at 4:34pm

Hello,

i'm trying to install Sliverstripe for a client.

The issue that i'm having is when I go to install it comes up with PHP 5 is required and the following warnings:

Warning: fopen(/tmp/silverstripe-cache-home-amoneypr-public_html-Site/manifest-main) [function.fopen]: failed to open stream: Permission denied in /home/amoneypr/public_html/Site/sapphire/core/ManifestBuilder.php on line 101

Fatal error: Cannot write manifest file! Check permissions of /tmp/silverstripe-cache-home-amoneypr-public_html-Site/manifest-main in /home/amoneypr/public_html/Site/sapphire/core/ManifestBuilder.php on line 105

Below is the phpinfo():

http://amoneyproblem.hostwebsite.co.nz/info.php

Avatar
Hamish

Community Member, 712 Posts

28 February 2009 at 4:55pm

That looks like a security issue. Maybe open_basedir restrictions are in effect or your host has locked up the tmp directory.

I believe you can override the default temp dir by creating a file "_ss_environment.php" in your website root, and defining TEMP_FOLDER there to be some other writable directory.

Avatar
JZM

Community Member, 34 Posts

28 February 2009 at 5:20pm

I have just spoken to the host and have been told open_basedir should be fine

Avatar
Willr

Forum Moderator, 5513 Posts

28 February 2009 at 5:55pm

I believe if you make a 'silverstripe-cache' folder in your root (same level as cms, sapphire etc folders) It will use this rather then /tmp/

Avatar
JZM

Community Member, 34 Posts

28 February 2009 at 6:07pm

i'm now getting

Parse error: syntax error, unexpected $end in /home/amoneypr/public_html/Site/mysite/code/Page.php on line 55

Avatar
Sam

Administrator, 685 Posts

2 March 2009 at 10:25am

Hrm, check that the mysite/code/Page.php file looks the same as this one:
http://svn.silverstripe.com/open/phpinstaller/tags/2.3.0/mysite/code/Page.php

If not, please let us know what it contains so that we can see if there's a bug lurking here.

Avatar
JZM

Community Member, 34 Posts

2 March 2009 at 4:44pm

Sam,

Used your code still the same the code seems dead from here on - line 18

      
// Note: you should use <% require %> tags inside your
templates instead of putting Requirements calls here. However
      // these are included so that our older themes still
work
      Requirements::themedCSS("layout");
      Requirements::themedCSS("typography");
      Requirements::themedCSS("form");
   }
   
   /**
    * Site search form
    */
   function SearchForm() {
      $searchText = isset($_REQUEST['Search']) ?
$_REQUEST['Search'] : 'Search';
      $fields = new FieldSet(
       new TextField("Search", "", $searchText)
       );
      $actions = new FieldSet(
       new FormAction('results', 'Search')
       );

       return new SearchForm($this, "SearchForm", $fields,
$actions);
   }
   
   /**
    * Process and render search results
    */
   function results($data, $form){
       $data = array(
       'Results' => $form->getResults(),
       'Query' => $form->getSearchQuery(),
       'Title' => 'Search Results'
       );

       return
$this->customise($data)->renderWith(array('Page_results', 'Page'));
   }
   
}

?>

Avatar
Sam

Administrator, 685 Posts

2 March 2009 at 5:12pm

Hi JZM,

It looks like this is due to PHP's asp_tags setting. Normally, it's off, but your host seems to have it set on.

For now, remove the "<% require %>" bit out of the comment. We'll fix this bug in 2.3.1.

Go to Top