Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

PHP 5 is required


Reply


26 Posts   6949 Views

Avatar
JZM

Community Member, 34 Posts

9 April 2009 at 6:50pm

If you could drop me a line ill give you a hand the chmod doesnt sound right

Avatar
hempster

Community Member, 4 Posts

9 April 2009 at 9:09pm

ok here we go:

i´ve uploaded the files freshly to my server, filled out the data and chmoded the files (via flashfxp ftp client) so that it looks something like this:
http://250kb.de/u/090409/j/8e82f8ca.jpg

mysql-date has been entered correctly as well:
http://250kb.de/u/090409/j/ffe1653e.jpg

when i start the installation i get this.....ooooops. wait:
http://250kb.de/u/090409/j/7ec7aaca.jpg

i could have sworn that i did everything exactly the same way i did it yesterday :)

THX for your help JZM anyway :D

Avatar
JZM

Community Member, 34 Posts

9 April 2009 at 9:14pm

Thats ok,

It seemed like a chmod issue, glad it works

Avatar
dconel

Community Member, 21 Posts

10 April 2009 at 8:46pm

I've got the smae problem:

# Creating 'mysite/_config.php'...
# Creating /home/dirk/domains/meifeest.com/public_html/mysite/_config.php
# Creating '.htaccess' file...
# Creating /home/dirk/domains/meifeest.com/public_html/.htaccess

Warning: fopen(/tmp/silverstripe-cache-home-dirk-domains-meifeest.com-public_html/manifestClassParse-_home_dirk_domains_meifeest.com_public_html_cms_code_AssetAdmin.php) [function.fopen]: failed to open stream: Permission denied in /home/dirk/domains/meifeest.com/public_html/sapphire/core/ManifestBuilder.php on line 398

Warning: fopen(/tmp/silverstripe-cache-home-dirk-domains-meifeest.com-public_html/manifestClassParse-_home_dirk_domains_meifeest.com_public_html_cms_code_AssetTableField.php) [function.fopen]: failed to open stream: Permission denied in /home/dirk/domains/meifeest.com/public_html/sapphire/core/ManifestBuilder.php on line 398

Warning: fopen(/tmp/silverstripe-cache-home-dirk-domains-meifeest.com-public_html/manifestClassParse-_home_dirk_domains_meifeest.com_public_html_cms_code_CMSActionOptionsForm.php) [function.fopen]: failed to open stream: Permission denied in /home/dirk/domains/meifeest.com/public_html/sapphire/core/ManifestBuilder.php on line 398
...
..
.
..
...

Fatal error: Cannot write manifest file! Check permissions of /tmp/silverstripe-cache-home-dirk-domains-meifeest.com-public_html/manifest-main in /home/dirk/domains/meifeest.com/public_html/sapphire/core/ManifestBuilder.php on line 105

I chmodded the file's but it wont work..

Avatar
Willr

Forum Moderator, 5513 Posts

10 April 2009 at 8:58pm

If you are having trouble with /tmp/ one option could be to create a 'silverstripe-cache' folder in your sites root folder (the one with sapphire/ cms/ etc) and give this chmod 777 and run http://yoursite.com/dev/build

Avatar
dconel

Community Member, 21 Posts

10 April 2009 at 9:06pm

Edited: 10/04/2009 9:12pm

Edit: It works! The name of the folder is relevant.

Thanks

Avatar
Willr

Forum Moderator, 5513 Posts

10 April 2009 at 9:11pm

yes. SilverStripe for the cache will look for a 'silverstripe-cache' folder (this is probably hardcoded in the core, may be able to override this) otherwise it will use /tmp/

Avatar
simon_w

Forum Moderator, 474 Posts

10 April 2009 at 9:49pm

You can manually define where the cache should be my defining TEMP_FOLDER in a _ss_environment.php file. The folder must exist, and lets you put the folder somewhere that you have access to outside of the site root.