Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

upload done and now what?


Go to End
Reply


19 Posts   3540 Views

Avatar
Sunnybex

Community Member, 39 Posts

2 March 2009 at 10:04am

Hi everyone,
a few weeks ago I decided to do my homepage myself after visting this page and downloading the silverstripe-stuff. And it worked very well so far, a very nice page with everything I need. An after a little research I finally found the "how to" - page to publish my stuff to my host hetzner, which you recommend somewhere, so I was pretty glad that it seemed to match.

OK, everything is uploaded, the theme is correct, php and sql seems ok and now: nothing happens. So: what next?? http://doc.silverstripe.com/doku.php?id=publishing-to-web-server is unfortunately very unclear here and I would appreciate some help.

Thanks in advance
Bex

Avatar
Hamish

Community Member, 712 Posts

2 March 2009 at 11:17am

You might have to elaborate on what "nothing happens" means.

I mean, like, step 1, the computer is on, right?

:P.

Seriously though, if you've uploaded everything you should see some sort of error when you go to your home page. Also check that you have the following line in your /mysite/_config.php file:

Director::set_environment_type('dev');

..to show better error messages.

Avatar
Sunnybex

Community Member, 39 Posts

2 March 2009 at 8:39pm

well, yes, computer is on and I am freezing, because all windows are open....

"nothing" meant, I klick on my webpage and there is still the "coming-soon"- site from the host.

I also checked the config.php and it shows

<?php

global $project;
$project = 'mysite';

global $databaseConfig;
$databaseConfig = array(
   "type" => "MySQLDatabase",
   "server" => "localhost",
   "username" => "root",
   "password" => "",
   "database" => "SS_mysite",
);

// Sites running on the following servers will be
// run in development mode. See
// http://doc.silverstripe.com/doku.php?id=devmode
// for a description of what dev mode does.

Director::set_environment_type('dev');

));

// This line set's the current theme. More themes can be
// downloaded from http://www.silverstripe.com/themes/
SSViewer::set_theme('highway');

?>

and there are still no changes in my website. I also asked hetzner for help, but they may be still sleeping...
I am confused.

Avatar
Hamish

Community Member, 712 Posts

2 March 2009 at 9:03pm

Ah.. where is that coming soon page coming from? Can you see it somewhere in your installation directory?

Maybe mod_rewrite is not enabled.

What you could do is - install a fresh base copy of silverstripe (ie, just grab that stable version, stick it on and go to the install page) - this will tell you if everything is set up correctly, or if the problem is not silverstripe.

Avatar
Sunnybex

Community Member, 39 Posts

2 March 2009 at 10:02pm

The "coming-soon-site" is the index.htm file in the directory where I put silverstripe in (as requested in the tutorial).

Avatar
Hamish

Community Member, 712 Posts

2 March 2009 at 10:26pm

Ah, well the routing rules will allow access to that file. Delete index.htm - this should force request to go through sapphire.

Avatar
Sunnybex

Community Member, 39 Posts

2 March 2009 at 11:08pm

Now it comes this:

Forbidden
You don't have permission to access / on this server.
Apache/1.3.34 Server at packaging-consulting.com Port 80

Hetzner required a index.htm file in this directory (in their tutorial)

and by the way: I really appreciate your help! Thanks a lot

Avatar
Sunnybex

Community Member, 39 Posts

3 March 2009 at 7:53am

Hi,

meanwhile I saved the "localhost-silverstripe-homepage" -site to a different computer folder, called it index.htm and loaded it (and the index files) on the sever, just to show the world, that there is something in progress.

Can I fix the problem with exchanging the word "silverstripe" with "mypersonalsite"? or is there any file I should change?
Hetzner still requires a index.htm file in the public_html folder.

Any ideas?
Thanks in advance

Go to Top