Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Don't use the tutorial files!


Reply


3 Posts   1405 Views

Avatar
Pyper

Community Member, 3 Posts

4 March 2009 at 12:37am

Dont use the tutorial files, go to http://ssorg.bigbird.silverstripe.com/installing-silverstripe/show/253631#post253631 and change your code to use one of the downloadable themes.

By all means go through the tutorials but if like me and your on a mac and you chose the tutorial "blank" install then it won't work (loads of problems for me anyway)

After I stoped using the /tutorial folder, all my errors and blank pages went away.

Good luck

Avatar
mio

Community Member, 1 Post

10 March 2009 at 10:39am

Hi Pyper,
thanks for your words of warning...Shame I only read them after altering my _config.php file! Now I have a blank page and no idea how to get my old _config.php file back. Any ideas?
Thanks

Avatar
Pyper

Community Member, 3 Posts

10 March 2009 at 10:04pm

Hi mio, dont worry if you have changed your _config.php file just replace it or make a new one:

<?php

global $project;
$project = 'mysite';
SSViewer::set_theme("whatever theme you want to use");

global $databaseConfig;
$databaseConfig = array(
   "type" => "MySQLDatabase",
   "server" => "localhost",
   "username" => "root",
   "password" => "root",
   "database" => "SS_mysite",
);

?>

Also remember to enter http://localhost:8888/silverstripe/db/build?flush=1 afterward so that it rebuilds everything.

Hope that helps,
Stuart.