Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Warnings after Installation on the WebServer


Go to End
Reply


9 Posts   3440 Views

Avatar
anthias

Community Member, 14 Posts

5 March 2009 at 3:51am

Hello. I am having problems with the installation on my web server.
After the CMS Installation Page and after Re-checking requirements (which were all ok) - I recieved the following window (also see the attached file):

"I am now running through the installation steps (this should take about 30 seconds)

If you receive a fatal error, refresh this page to continue the installation

Warning: unlink(mysite/_config.php) [function.unlink]: Permission denied in /www/htdocs/w00abc52/install.php on line 709
* Creating 'mysite/_config.php'...
* Creating /www/htdocs/w00abc52/mysite/_config.php
* Creating '.htaccess' file...
* Creating /www/htdocs/w00abc52/.htaccess

Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(../../_ss_environment.php) is not within the allowed path(s): (/www/htdocs/w00abc52/:/tmp:/usr/bin:/www/htdocs/w00abc52:/bin:/usr/local/bin:/usr/share/php) in /www/htdocs/w00abc52/sapphire/core/Core.php on line 31

Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(../../../_ss_environment.php) is not within the allowed path(s): (/www/htdocs/w00abc52/:/tmp:/usr/bin:/www/htdocs/w00abc52:/bin:/usr/local/bin:/usr/share/php) in /www/htdocs/w00abc52/sapphire/core/Core.php on line 31
* Building database schema...
* Checking that friendly URLs work...
* Friendly URLs are not working. This is most likely because mod_rewrite isn't configuredcorrectly on your site. Please check the following things in your Apache configuration; you may need to get your web host or server administrator to do this for you:
o mod_rewrite is enabled
o AllowOverride All is set for your directory"

At the moment, i have no idea - how to solve this. I am grateful for any suggestions.
Thanks in advance!

Attached Files
Avatar
Stephan

Community Member, 55 Posts

6 March 2009 at 6:17am

Hi experts,
I do have exactly the same problem.
Please help.
What can we do ?

TIA
Stephan

Avatar
anthias

Community Member, 14 Posts

6 March 2009 at 11:38pm

Hello again.
Except the warning outputs as described earlier I am getting this (see attached file) - when opening my url.

Anyone any idea? Probably a common error output, isn't it?

Attached Files
Avatar
froschi

Community Member, 2 Posts

7 March 2009 at 11:26am

same probem here...

any solutions so far ???

greetings,

froschi

Avatar
Willr

Forum Moderator, 5513 Posts

7 March 2009 at 10:57pm

Looks like you have safe_mod turned on in your php install. Some shared hosts do this. I think if you create a blank file '_ss_environment.php' file in the same folder as the one you have cms/ sapphire/ folders then it should get round this issue.

Avatar
anthias

Community Member, 14 Posts

7 March 2009 at 11:15pm

Yes! Thanks a lot! That solved the problem.
Greets from Austria,
T

Avatar
froschi

Community Member, 2 Posts

8 March 2009 at 10:29am

this solution does'nt work for me.
Safe_mode is "off" in my enviroment and
putting the blank file '_ss_environment.php'
to the silverstripe folder gives me:

Warning: unlink(mysite/_config.php) [function.unlink]: Permission denied in /is/htdocs/wp1140410_VC24OHRC4B/www/install.php on line 709
# Creating 'mysite/_config.php' for use with _ss_environment.php...
# Creating /is/htdocs/wp1140410_VC24OHRC4B/www/mysite/_config.php
# Creating '.htaccess' file...
# Creating /is/htdocs/wp1140410_VC24OHRC4B/www/.htaccess

Fatal error: SS_DATABASE_PASSWORD must be defined in your _ss_environment.php. See http://doc.silverstripe.com/doku.php?id=environment-management for more infomration in /is/htdocs/wp1140410_VC24OHRC4B/www/sapphire/conf/ConfigureFromEnv.php on line 46

Avatar
Sam

Administrator, 685 Posts

9 March 2009 at 10:08am

You can't have a blank _ss_environment.php file - fill it out as instructed on http://doc.silverstripe.com/doku.php?id=environment-management

Go to Top