Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Problem installing - allow_call_time_pass


Reply

3 Posts   1227 Views

Avatar
dreamstudio

5 March 2009 at 6:46am (Last edited: 5 March 2009 11:29am), Community Member, 48 Posts

We are trying to install silverstripe.. We originally come up with an error saying we had php4 and not 5.... the host company told us to add SetEnv DEFAULT_PHP_VERSION 5 to the .htaccess file and now we can see its using php5

So we start on the install page... we also had an error about the allow_call_time_pass_reference. Its showing as orange and all we try doesnt work, Spoke with server company and we setup a php5.ini file.. this seems to work and we just have the orange text about mod_rewrite enabled... Says it cant tell. Well I run a test script that rewrites a link to google and that means mod rewrite is on and our host confirms its on.

So continue and try to install. I have left the development servers as localhost and 127.0.0.1 Im going to be working online and not locally.. and not sure if these details needs changing or not?

Click install and we get this message

Installing SilverStripe...
I am now running through the installation steps (this should take about 30 seconds)

If you receive a fatal error, refresh this page to continue the installation

Creating 'mysite/_config.php'...
Creating /home/sites/dgsmyourchoice.org.uk/public_html/mysite/_config.php
Creating '.htaccess' file...
Creating /home/sites/dgsmyourchoice.org.uk/public_html/.htaccess
Building database schema...
Checking that friendly URLs work...
Friendly URLs are not working. This is most likely because mod_rewrite isn't configuredcorrectly on your site. Please check the following things in your Apache configuration; you may need to get your web host or server administrator to do this for you:
mod_rewrite is enabled
AllowOverride All is set for your directory

So its getting stuck here... Host company says everything is in place and its down to the software, Im not sure if the development server details need changing or what else i can do... it just wont install and I have deleted all the files and reloaded and still nothing

Avatar
dreamstudio

5 March 2009 at 7:33am (Last edited: 5 March 2009 11:29am), Community Member, 48 Posts

(removed this... certain details got fixed so I tried making this simpler )

Avatar
dreamstudio

5 March 2009 at 11:42am Community Member, 48 Posts

So im stuck.... do i need to change the developer server settings ie 127.0.0.1 or local host.... or how can i see why its not installing... i feel im so close but stuck without being able to install it...