Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Installation gets stuck


Reply

3 Posts   1432 Views

Avatar
dreamstudio

6 March 2009 at 5:31am Community Member, 48 Posts

Hi

We are trying to install on a shared hosting with Heart internet... we solved the problems of checking mod rewrite is working and we try to install and it starts but ends up getting stuck when installing on the friendly url issue... From what we can see our hosting can offer everything thats needed and we cant seem to continue the installation

Is there a way to not install the friendly URL feature or to turn off the checking for this so we can at least get it installed and then check it all works?

Avatar
dreamstudio

6 March 2009 at 7:17pm Community Member, 48 Posts

I solved the problem by just changing the htaccess file in the root of the website folder.

I added
SetEnv DEFAULT_PHP_VERSION 5
AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php

The first setenv line told the server to use php5 and not PHP4 as it was doing ( its running both ) then the two add lines allowed the install to get past the modrewrite stopping upon install

I am using Heart Internet in the UK if anyone else has this problem getting it to work with them ( or maybe other hosting sites too )

Avatar
dreamstudio

6 March 2009 at 7:17pm Community Member, 48 Posts

I solved the problem by just changing the htaccess file in the root of the website folder.

I added
SetEnv DEFAULT_PHP_VERSION 5
AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php

The first setenv line told the server to use php5 and not PHP4 as it was doing ( its running both ) then the two add lines allowed the install to get past the modrewrite stopping upon install

I am using Heart Internet in the UK if anyone else has this problem getting it to work with them ( or maybe other hosting sites too )