Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Installing 2.3 not working - see result


Go to End
Reply


12 Posts   4085 Views

Avatar
steve_nyhof

Community Member, 224 Posts

7 March 2009 at 3:46am

Installing SilverStripe...
I am now running through the installation steps (this should take about 30 seconds)

If you receive a fatal error, refresh this page to continue the installation

Creating 'mysite/_config.php'...
Creating /home/websider/public_html/mysite/_config.php
Creating '.htaccess' file...
Creating /home/websider/public_html/.htaccess
Building database schema...
[Warning] Cookie 'alc_enc' can't be set. The site started outputting was content at line 656 in /home/websider/public_html/install.php
POST //install.php
Line 21 in /home/websider/public_html/sapphire/core/Cookie.php

Source
12     * @param name The variable name
13     * @param value The variable value. May be an array or object if you wish.
14     * @param expiryDays The expiry time, in days. Defaults to 90.
15     */
16    static function set($name, $value, $expiryDays = 90) {
17       if(!headers_sent($file, $line)) {
18          $expiry = $expiryDays > 0 ? time()+(86400*$expiryDays) : 0;
19          setcookie($name, $value, $expiry, Director::baseURL());
20       } else {
21          if(self::$report_errors) user_error("Cookie '$name' can't be set. The site started outputting was content at line $line in $file", E_USER_WARNING);
22       }
23       $_COOKIE[$name] = $value;
24    }
25    
26    /**
27     * Get a cookie variable

Trace
Cookie 'alc_enc' can't be set. The site started outputting was content at line 656 in /home/websider/public_html/install.php
Line 21 of Cookie.php
Cookie::set(alc_enc,1:96801e883a9d8dee5dff8fa592607d54)
Line 266 of Member.php
Member::autoLogin()
Line 399 of Member.php
Member::currentUser()
Line 149 of Folder.php
Folder->constructChild(SilverStripeLogo.png)
Line 107 of Folder.php
Folder->syncChildren()
Line 112 of Folder.php
Folder->syncChildren()
Line 107 of Filesystem.php
Filesystem::sync()
Line 811 of install.php
Installer->install(Array)
Line 123 of install.php

Avatar
maggieo

Community Member, 2 Posts

8 March 2009 at 10:01am

I got round this by deleting the installation and then re-installing using the black candy theme instead of the tutorial.

Avatar
steve_nyhof

Community Member, 224 Posts

14 March 2009 at 2:31am

Edited: 14/03/2009 2:48am

Can you please expound a little on your comment.

I upload all my files to the server.
Type in the domain name to begin installation.
The system defaults to the blackcandy theme.
Enter my details.
Click the button to install.

Do I install the system first using the tutorial?
Then if/when it fails, install the blackcandy? what should I do? Please explain more the steps you took to do this.

Thank you,
Steve

I should add that I have never installed with the tutorial before

Avatar
steve_nyhof

Community Member, 224 Posts

14 March 2009 at 2:47am

I just uploaded all the files to a new domain.
Typed in the domain name and this is the result...

Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(../../../_ss_environment.php) is not within the allowed path(s): (/home/homemain:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/homemain/public_html/sapphire/core/Core.php on line 31

Can someone who knows what this means please help?
Thank you,
Steve

Avatar
Nickt

Community Member, 43 Posts

23 March 2010 at 6:25pm

i am having the EXACT same problem so please help. thanks

Avatar
steve_nyhof

Community Member, 224 Posts

24 March 2010 at 1:37am

This was a long time ago. Seems most of these type problems come from something on the server not being compatible. You may need to check with your host and something with the php.ini file - check other posts for this.

Avatar
BigChris

Community Member, 63 Posts

29 March 2010 at 9:57pm

This is happening due to the value of the open_basedir being set in the php configuration.
This may be solved by editing the php.ini file, by changing the value of open_basedir or commenting it out.

Avatar
ahojan

Community Member, 4 Posts

31 March 2010 at 9:13pm

Edited: 04/04/2010 4:17pm

Dear SilverStripe masters!

The stable version 2.3.7 is installed 4x started ...
Every time I got only so far:
http://www.lapon.hu/images/installSS.jpg
and
http://cmsdemo.lapon.hu/silverstripe/

There is also a silverstripe-v2.4.0-beta1 has been successfully installed.
http://cmsdemo.lapon.hu/silverstripe/

I would like to try a stable version 2.3 ...
Or wait until the final 2.4 ?
When will final 2.4 ?
Please answer!

Kind Regards
ahojan

Go to Top