Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

SS install fails on temporary site URL


Reply


2 Posts   1613 Views

Avatar
Moose

Community Member, 26 Posts

17 March 2009 at 1:58am

Hi

I have a server that allows a site preview for a site not yet mapped to its URL. I have uploaded the latest Silverstripe package to the root directory. When I browse to the temporary URL (that shows an index.htm file correctly , for example) I get a general failure -

Website Error
There has been an error

The website server has not been able to respond to your request.

If i try force the RewriteBase to point to the https address of the temporary URL I get an internal server error.

Is there a way around this? Help would be much appreciated as I often roll sites out on temp URL's until I get sign off.

Thanks!!

Avatar
Moose

Community Member, 26 Posts

17 March 2009 at 8:28pm

Edited: 17/03/2009 9:27pm

I just realised that the version of SS I was uploading had already had the _config file altered by a local install process! Dohhh! The install still doesn't work on the temp site though - it tries to load www.mydomain.com/install.php. Is there a way I can force this to be https://mydomainpreviewserverURL/install.php?
Thanks!