Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Error during installation SS-2.3.1


Reply

915 Views

Avatar
drla

29 March 2009 at 12:55pm Community Member, 1 Post

Hi,

I'm trying new version of SS 2.3.1, I worked with 2.3.0 and 2.2.3 and everything was fine. During installation SS give me back this error...

[User Error] Couldn't find ID in array ( 'fields' => array ( 'ID' => '0', 'ShowInMenus' => '1', 'ShowInSearch' => '1', 'Status' => '\'Published\'', 'CanViewType' => '\'Inherit\'', 'CanEditType' => '\'Inherit\'', 'Title' => '\'Home\'', 'Content' => '\'Welcome to SilverStripe! This is the default homepage. You can edit this page by opening the CMS. You can now access the developer documentation, or begin the tutorials.\'', 'URLSegment' => '\'home\'', 'LastEdited' => 'now()', 'Created' => 'now()', 'ClassName' => '\'Page\'', ), 'command' => 'insert', 'id' => 0, )
POST /gotravel/install.php

Line 258 in C:\xampp\htdocs\gotravel\sapphire\core\model\Versioned.php

Trace

* Couldn't find ID in array ( 'fields' => array ( 'ID' => '0', 'ShowInMenus' => '1', 'ShowInSearch' => '1', 'Status' => '\'Published\'', 'CanViewType' => '\'Inherit\'', 'CanEditType' => '\'Inherit\'', 'Title' => '\'Home\'', 'Content' => '\'<p>Welcome to SilverStripe! This is the default homepage. You can edit this page by opening <a href=\\"admin/\\">the CMS</a>. You can now access the <a href=\\"http://doc.silverstripe.com\\">developer documentation</a>, or begin <a href=\\"http://doc.silverstripe.com/doku.php?id=tutorials\\">the tutorials.</a></p>\'', 'URLSegment' => '\'home\'', 'LastEdited' => 'now()', 'Created' => 'now()', 'ClassName' => '\'Page\'', ), 'command' => 'insert', 'id' => 0, )
Line 258 of Versioned.php
* Versioned->augmentWrite(Array,,,,,,)
Line 471 of Object.php
* Object->extend(augmentWrite,Array)
Line 825 of DataObject.php
* DataObject->write()
Line 932 of SiteTree.php
* SiteTree->requireDefaultRecords()
Line 210 of DatabaseAdmin.php
* DatabaseAdmin->doBuild(1)
Line 797 of install.php
* Installer->install(Array)
Line 123 of install.php

Knows anybody where is problem??? Thanks