Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Friendly url not-working, .htaccess config ? (Infomaniak hosting)


Go to End
Reply


13 Posts   9603 Views

Avatar
Daoro

Community Member, 5 Posts

3 April 2009 at 8:47am

First, thanks for your support :)
It's still not working, I can't complete the installation (same error message as in my first post).

But it's quite normal I suppose.
What I want is Silverstripe to be installed in the my /ss folder for now, because I want to test if Silverstripe can be installed and setup without having to close or change the site for now. So even if it worked setting the rewrite base to / is not what I want.
Concerning moving the installation outside the root folder and / or change the httpd.conf, it's not possible. I'm using a shared hosting and can't do that :/

And I can't access anything using unrewritten URLs :(

Avatar
FungshuiElephant

Community Member, 57 Posts

3 April 2009 at 11:54am

What I want is Silverstripe to be installed in the my /ss folder for now, because I want to test if Silverstripe can be installed and setup without having to close or change the site for now.
Your original .htaccess looks right for this.

Time to look elsewhere. You say in your original post:
I renamed every HTTPResponse instance to something else successfully, preventing conflit with the php config of my host.
How did you do this?
Did you rename HTTPResponse.php to refelect your new name?

Avatar
Daoro

Community Member, 5 Posts

9 April 2009 at 12:31am

A global "find and replace" to change all the strings + renaming the file. But I suppose this part went fine.

Avatar
datswicked

Community Member, 15 Posts

26 June 2013 at 11:41pm

Edited: 26/06/2013 11:41pm

I Know this is an old post, but had htaccess not work on a server i knew it was active on and i solved like this.

...
#<IfModule mod_rewrite.c>
   SetEnv HTTP_MOD_REWRITE On
   RewriteEngine On
   RewriteBase /

   RewriteCond %{REQUEST_URI} ^(.*)$
   RewriteCond %{REQUEST_FILENAME} !-f
   RewriteCond %{REQUEST_URI} !\.php$
   RewriteRule .* framework/main.php?url=%1&%{QUERY_STRING} [L]
#</IfModule>

basically commenting out the <ifModule> and closing </ifModule>

was ready to tear my hair out till i tried that and BINGO, worked like a charm..
on Linus, PHP 5.3.18, Silverstripe 3.0.5

Avatar
Benwitz

Community Member, 7 Posts

19 July 2013 at 4:10am

The following may just be a warning, sometimes a warning in error as mod_rewrite is active. If you get this when installing try accessing your root page directly "www.mysite.com" and chances are your install was successful regardless of the warning.

"Friendly URLs are not working. This is most likely because mod_rewrite isn't configured correctly on your site. Please check the following things in your Apache configuration; you may need to get your web host or server administrator to do this for you: "

* mod_rewrite is enabled
* AllowOverride All is set for your directory

Go to Top