Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

The website server has not been able to respond to your request. after install........


Reply

10 Posts   6993 Views

Avatar
jlm

19 April 2010 at 6:12pm Community Member, 2 Posts

Thanks for the help Willr. I did as instructed, which provided a detailed Error message listing a problem with a php file in sapphire/core/ directory, which didn't make sense because I only touched tutorials/template/ files and the mysite/code/ files.

But as the mysite/code/ directory also contains php files, I figured I had a misnamed file in there. So I opened up one of the files I created in there in tutorial 2, commented out a php line, saved the file, refreshed the browser to find a much longer and more detailed error message. so I undid my commenting out, saved the file, refreshed the browser to find the original error message gone. I don't know what fixed it.

And continued on with tutorial 2, or tried to, until my lack of knowledge of php got too difficult and I decided I really need to understand php more before continuing... I hope to come back soon.

Avatar
Willr

19 April 2010 at 7:05pm Forum Moderator, 5511 Posts

Hi Jim,

Yes debugging PHP is sometimes quite scary and challenging if you haven't run into the issue before. If you post the full error message and the backtrace normally we can fix the error up and get you in the right direction pretty quick.