Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

I'm not sure if it is installed successfully?


Go to End
Reply


10 Posts   3886 Views

Avatar
zcm211

Community Member, 18 Posts

17 April 2009 at 3:39am

Edited: 17/04/2009 3:53am

The installing page shows below:

Installing SilverStripe...
I am now running through the installation steps (this should take about 30 seconds)

If you receive a fatal error, refresh this page to continue the installation

Creating 'mysite/_config.php'...
Creating D:\Program Files\Apache Software Foundation\Apache2.2\webapp\SilverStripe\mysite/_config.php
Creating '.htaccess' file...
Creating D:\Program Files\Apache Software Foundation\Apache2.2\webapp\SilverStripe\.htaccess
Building database schema...
Checking that friendly URLs work...
Friendly URLs are not working. This is most likely because mod_rewrite isn't configuredcorrectly on your site. Please check the following things in your Apache configuration; you may need to get your web host or server administrator to do this for you:
mod_rewrite is enabled
AllowOverride All is set for your directory

Avatar
gakenny

Community Member, 153 Posts

17 April 2009 at 12:38pm

Hello,

The installation did not complete successfully. Please verify that this has been enabled:
mod_rewrite is enabled
AllowOverride All is set for your directory

Cheers,

Gary

Avatar
zcm211

Community Member, 18 Posts

19 April 2009 at 3:57am

I've already Load the rewrite model, doesn't it finish?

LoadModule rewrite_module modules/mod_rewrite.so

Although I did not install successfully, but I can use silverstripe normally. Should I ignore these warnings?

Avatar
Sigurd

Forum Moderator, 628 Posts

19 April 2009 at 2:22pm

Looks like it is fine.

SilverStripe 2.3.1 allows you to install without mod_rewrite being configured in the way SilverStripe needs; you just get slightly less user friendly URLs.

Avatar
zcm211

Community Member, 18 Posts

19 April 2009 at 7:35pm

Thank you for your reply, I can continue my work.

Avatar
Afterword

Community Member, 5 Posts

24 April 2009 at 3:36am

how to make it work after this

Friendly URLs are not working. This is most likely because mod_rewrite isn't configuredcorrectly on your site. Please check the following things in your Apache configuration; you may need to get your web host or server administrator to do this for you:
mod_rewrite is enabled
AllowOverride All is set for your directory

when try to go url: \silverstripe

it write The requested page couldn't be found.

what can i do to do this work?

Avatar
Sigurd

Forum Moderator, 628 Posts

24 April 2009 at 8:48am

Once you saw that error did it not carry on to show a working SilverStripe site?

Please explain as much as you can about versions of your PHP, OS, etc, etc.

Avatar
Afterword

Community Member, 5 Posts

24 April 2009 at 7:09pm

Yes, I don't see any default page, as write in tutorial.
If it's error normal why i don't see first default page

OS: Windows XP
PHP : php-5.2.5-Win32
Apache: Apache2.2

Go to Top