Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

2.3.1 install errors


Reply

7 Posts   3061 Views

Avatar
Alamax

20 April 2009 at 12:46pm Community Member, 3 Posts

I am installing 2.3.1 on IIS 5.1 on an XP box.

I followed the manual install procedure.

On first time run I received the following errors:

Deprecated: Function ereg_replace() is deprecated in C:\inetpub\wwwroot\silverstripe\install.php on line 357

Line of code for above error: $c = ereg_replace('-.*$','',$c);
install.php file attached

Parse error: parse error in C:\inetpub\wwwroot\silverstripe\sapphire\dev\install\config-form.html on line 178

Line 178 is the final line of html code for this error
config-form.html file attached

Attached Files
Avatar
Sigurd

21 April 2009 at 2:24pm Forum Moderator, 628 Posts

What version of PHP are you running?

I thought this is deprecated in PHP 5.3 and above, which is not yet out?

Avatar
Alamax

23 April 2009 at 3:03pm Community Member, 3 Posts

Hi Sigurd,

Thanks for your reply.

Sorry it took so long to get back to the post.

Yes, I am running php 5.3.

I presume that, since you asked, Silverstripe will be a while putting out a version that deals with the pending deprecations beyond php version 5.9.2.

So....

Before I back up to 5.9.2, has anyone attempted a work around?

Avatar
Mo

30 April 2009 at 3:38am Community Member, 509 Posts

I am having this exact error with 5.2.9.

I would also love to know if anyone has come up with a workaround?

Mo

Avatar
Sigurd

2 May 2009 at 12:32am Forum Moderator, 628 Posts

Added bug report to http://open.silverstripe.com/ticket/3973 :)

Avatar
ezra

4 May 2009 at 2:13pm Community Member, 2 Posts

Also - if you're using WAMP this post may be helpful - http://silverstripe.org/installing-silverstripe/show/257713#post257713

Avatar
xterso

7 July 2009 at 8:17pm Community Member, 6 Posts

I checked the bug report and it says;

"I've disabled E_DEPRECATED as a quick fix, so lowering this item's priority."

This is not true. I disabled E_DEPRECATED as well but this has no effect. I still get the following error.

"PHP Deprecated: Function ereg_replace() is deprecated in C:\inetpub\wwwroot\sapphire\core\ManifestBuilder.php on line 257"

Not any fix yet? I am stuck.