Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Logins Fail when migrating to new server


Reply


3 Posts   1316 Views

Avatar
Double-A-Ron

Community Member, 604 Posts

27 April 2009 at 9:13am

Edited: 27/04/2009 9:55am

Does anyone else have an ongoing problem when trying to move or make a copy of an existing Silverstripe site?

Here's the senario:

1. I have a Silverstripe site online and live
2. I am wanted to upgrade this site to 2.3.1
3. I make a copy of the live database and copy it to a WAMP localhost (Yes, table case names are exactly the same)
4. When I try to login to the dev site using the same login that works on the live site, it fails.

I have tried copying the database by downloading a dump from PHPMyAdmin and using SQLYog to sync the two. Both have the same result. The copied site seems to function, but I cannot get into the CMS or do a db/build.

Any ideas? This is a consistant problem I have noticed for months using two different workstations running WAMP.

It has to be something quirky with SS. I do similar copies with Drupal and Wordpress no problems at all.

Cheers
Aaron

Avatar
Willr

Forum Moderator, 5513 Posts

28 April 2009 at 5:29pm

One of the issues I sometimes run into which is like this is when the way password encryption works is different. SilverStripe uses a couple different hashing methods to protect the password (not at the same time!) and these often rely on floating point numbers or precision variables which can be different on some setups.

No idea what WP / Drupal do to get round this or if this is even the bug that you are experiencing. Maybe try hard coding a member login in your _config file - Security::setDefaultAdmin('admin', 'password'); then logging in with that to change your password then logout and try with your account again.

Avatar
Double-A-Ron

Community Member, 604 Posts

29 April 2009 at 12:16am

Thanks Will,

That's exactly what I have been doing in the config file. I'm just trying to work out possible causes as this will be a rather common operation.

Cheers
Aaron