Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Getting 404 error admin login


Reply


4 Posts   403 Views

Avatar
Scalatron

Community Member, 2 Posts

19 July 2014 at 9:29pm

Hi, I'm new to SS. I downloaded and installed without issue but can't get to the admin login page (http://localhost/silverstripe/admin). I just get 404 page not found. The server is IIS8.5 on Win8. I'm guessing it's a pathway issue due to not installing in root??? Where do I change this in the code?

Thanks :-)

Avatar
Kirk

Community Member, 45 Posts

21 July 2014 at 2:56pm

SilverStripe uses URL rewriting maybe this has not been set up on your Windows environment have you have any other web frameworks setup on this machine which have used URL rewriting.

Also have you been able to load any other urls like the following http://localhost/silverstripe/dev/build?flush=all

Avatar
Scalatron

Community Member, 2 Posts

21 July 2014 at 11:20pm

Edited: 21/07/2014 11:21pm

Hi thanks for your reply.

I have the URL rewrite module installed, not sure if I use any other sites using URL rewrite, I'm running WordPress and that's fine. What settings does the rewrite module need, I'm not familiar with it? I can't load http://localhost/silverstripe/dev/build?flush=all again I get 404 Not Found. I can view the Silver Stripe user site, it's just the admin that won't load.

Avatar
Kirk

Community Member, 45 Posts

22 July 2014 at 9:13am

Don't have much experience running SilverStripe on Windows but on a LAMP environment a .htaccess file is used to direct all requests to framework/main.php?url=admin
I think this is done by a web.config file on windows (or used to be)

Maybe try these urls

http://localhost/silverstripe/framework/main.php?url=dev/build
http://localhost/silverstripe/framework/main.php?url=admin