Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Installation stops at "PHP 5 is required"


Go to End
Reply


12 Posts   5392 Views

Avatar
Gravitational FX

Community Member, 22 Posts

16 July 2009 at 4:49am

Well, in my case it was the Fast CGI that fasthosts.co.uk use.

I finally got them to look at the .htaccess rewrite requirements for SilverStripe and they admitted that their system only allows simple .htaccess commands.

They basically can't support SilverStrip, joomla, wordpress or anything else that requires rewrites, so I'm guessing in my case that the install crashed out and incorrectly reported the PHP 5 required message.

Moved to another hosting company that doesn't use Fast CGI - works a treat now!

I guess I need to be carefull when customers already have a hosting plan to check that their system will indeed support the proposed CMS, although I was pretty surprised that with fasthosts claiming to be the UK's #1 ISP, they don't support pretty much 99% of all the current web design packages.

Hey ho.

Avatar
PentaMedia.biz

Community Member, 1 Post

3 August 2009 at 1:34am

Hey!

My installation also stops at PHP 5 is required and my host use:
IIS 6
PHP 5
MySQL 5

Could IIS be the problem and anyone know how to solve this?

Regards!
//
Izaac

Avatar
supermegaultra

Community Member, 33 Posts

25 January 2010 at 2:55pm

Like most of you, I have the same issue..

Although I think the main problem I have is that my client wants his new website hosted with Telecom. Ohh dear..

..Anyway, all the hosting requirements were met except for the mod_rewrite nonsence.

I'm getting Telescum to look into adding the [url=http://www.iis.net/expand/URLRewrite]URL Rewrite Module[/url] for me now which hopefully should fix this issue.

I'll let you know how it goes!

Avatar
SnowBoarder82

Community Member, 52 Posts

27 August 2011 at 8:48am

Hi Supermegaultra,

I noticed your post while searching the forum about Telecom's hosting. I have a client who also wants to use Telecom and have run into the same hurdle with mod_rewrite not being enabled. So far the support crew from Telecom has not been much help. I was hoping that you could share if and how you were able to resolve this with Telecom...

Thank you,

Go to Top