Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

MySQL troubles with server changes


Reply


4 Posts   1074 Views

Avatar
pangpang

Community Member, 1 Post

16 May 2009 at 11:14pm

Hi!

Read through the forum and other channels aviable. But my problem is still to be answered.

Everything works fine on my local WAMP setup and the problem accours when I move from my personal test server to a live server.

Tried a fresh install on the new server, then uploaded specific files and images and exported the database and imported it on the live server. And I even tried a update and replace statement.

The problem is that on my localserver all the tables are in written like tablea, tableb, tablec and so on. But on the live server everything goes like TableA, TableB, TableC and so on. And this happens with I flush the db to try to build again. With just an import SS wouldnt find the tables.

So with an database import, update and so on on the live server fails with the site.

There is no problems with the mysql side. Just that the difference in the namesetting on the live and personal server.

How do I fix this matter?

Avatar
Mindfusion

Community Member, 7 Posts

17 December 2010 at 1:52pm

Hello,

Did anyone find a workaround for this or do i have to manually type in the table names in mysql dump (i hope there is a better solution)

Avatar
Mindfusion

Community Member, 7 Posts

17 December 2010 at 3:48pm

Replaced the table names in my mysql dump file and got and error when i tried to run dev/build . Is there a solution to exporting from my windows dev machine to a linux server?

Avatar
Mindfusion

Community Member, 7 Posts

17 December 2010 at 10:57pm

Found solution at http://open.silverstripe.org/ticket/2476