Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

date.timezone option in php.ini must be set correctly.


Reply


4 Posts   613 Views

Avatar
thomas.paulson

Community Member, 86 Posts

5 August 2014 at 12:30am

I know that timezone must be set correctly, but I have set timezone correctly in php.ini ie Asia/Calcutta. And i cant move forward with installation.

After a while I thought to change timezone to London, and this time there is not error

date.timezone = Europe/London
;date.timezone = Asia/Calcutta

it would be great if somebody could why my timezone ie Asia/Calcutta did not work.

Thanks

Avatar
Kirk

Community Member, 45 Posts

5 August 2014 at 10:03am

Tried this on my machine and I am able to replicate this I get the following error

date.timezone setting and validity   date.timezone option in php.ini must be set correctly.

I am thinking this could be related to the version of Apache/PHP I am using PHP 5.3.28 and Apache 2.2.26 running on Macports.

Can you advise on what version of Apache and PHP you are using.

Avatar
Kirk

Community Member, 45 Posts

5 August 2014 at 10:18am

It is not actually related to the version of PHP or Apache it needs to be added as

date.timezone = Asia/Kolkata;

Calcutta is the historical English name for Kolkata as per the wiki [url]http://en.wikipedia.org/wiki/Kolkata[/url]

Avatar
thomas.paulson

Community Member, 86 Posts

5 August 2014 at 3:05pm

Thanks Kirk, you are right it date.timezone = Asia/Kolkata

I was following the below link, and there are two entries ie Asia/Calcutta & Asia/Kolkata , I did not notice the later one.

http://php.net/manual/en/timezones.asia.php

Thanks again Kirk for pointing me in right direction, I cant believe why i did not notice that; though I am based in India