Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Random CMS Forbidden error


Go to End
Reply


40 Posts   7901 Views

Avatar
Briohny

Community Member, 199 Posts

22 May 2009 at 4:16am

I've done loads of SS installations but this is the first of it's kind. First time with this host too... easyspace.com

All files are uploaded. Live site is working perfectly. CMS is being very weird. Here is what it's doing:

1) Sometimes you can log in no problem. Then sometimes when you log in it tells you that you are logged in as #### but you are still at the login screen. Refresh a few times, re-login and then randomly you'll make it to the CMS main screen

2) Sometimes when you select a page to edit, it comes up with a "forbidden" error followed by an "error loading page". Keep hitting the page to edit and eventually it will appear ready for editing.

3) Sometimes when you go to save a page, it comes up with "error saving page". Keep hitting save & publish and eventually it will save.

I have no idea what is going on. Guessing it's a .htaccess problem, but i really need someone to shed some light. It's really no good for my client if it operates like this.

Avatar
Willr

Forum Moderator, 5513 Posts

22 May 2009 at 11:43am

error saving page is the generic error message - if you have firebug installed and you are running the site in devmode you can view the firebug console to see the actual error.

If it comes and goes it could be a memory issue, the mysql connection dropping / starting inbetween publishes or some other variable thats not constant.

Try installing firebug + putting the site in devmode to view the proper error which will be a clue

Avatar
Briohny

Community Member, 199 Posts

22 May 2009 at 7:58pm

Thanks Will. I've installed Firebug. I've never used it before. I have it open but what am i looking for exactly?

Avatar
Briohny

Community Member, 199 Posts

22 May 2009 at 8:02pm

Ok... I tried to log in and open a page. The following error occurred. It's telling me i'm not logged in... i think. See attached screen shot. What does this mean?

Attached Files
Avatar
Briohny

Community Member, 199 Posts

22 May 2009 at 8:04pm

Ok, same error if i try and save a page. It's obviously logging me out randomly and then re-logging me in. Maybe this would explain why on the log in page, it says i'm logged in but still keeps me at the log in page.

How can i fix this please?

Avatar
Briohny

Community Member, 199 Posts

23 May 2009 at 3:08am

Also just noticed that my image upload section (within the CMS) is acting strange too. Randomly again giving me forbidden errors. See attached.

Can anyone shed some light? I really need this fixed.

Attached Files
Avatar
Briohny

Community Member, 199 Posts

23 May 2009 at 3:11am

Just noticed that the host has PHP5.1.6 instead of PHP5.2 - could this be the issue?

Avatar
Briohny

Community Member, 199 Posts

25 May 2009 at 9:00pm

Bump bump :) Can someone please shed some light??

Go to Top