Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

mod_rewrite enabled


Reply


6 Posts   3395 Views

Avatar
amarbhanu

Community Member, 57 Posts

10 June 2009 at 7:13pm

You need mod_rewrite to run SilverStripe CMS, but it is not enabled.

this massage send wamp when installation silverstripe, please suggest me how can remove it.

Avatar
banal

Community Member, 901 Posts

10 June 2009 at 7:23pm

Enable mod_rewrite?
http://roshanbh.com.np/2008/04/check-enable-mod_rewrite-apache.html

Avatar
amarbhanu

Community Member, 57 Posts

10 June 2009 at 8:17pm

banal thanks...

Avatar
jujudellago

Community Member, 1 Post

24 June 2009 at 3:49am

Hi,

I have issues instaling silverstripe on my development machine (mac osx leopard)

I am absolutely sure mod_rewrite is working fine, I can see it in the loaded modules with a <?php phpinfo(); ?> and it's working fine on other CMS installations (I.E. Wordpress)

The documentations says silverstripe can be installed without mod_rewrite, in that case I don't know how that can be achieved, as the installer always hangs:

------------------------------------------------------------

# Creating 'mysite/_config.php'...
# Creating /Users/juju/Sites/silverstripe/mysite/_config.php
# Creating '.htaccess' file...
# Creating /Users/juju/Sites/silverstripe/.htaccess
# Building database schema...
# Checking that friendly URLs work...
# Friendly URLs are not working. This is most likely because mod_rewrite isn't configuredcorrectly on your site. Please check the following things in your Apache configuration; you may need to get your web host or server administrator to do this for you:

* mod_rewrite is enabled
* AllowOverride All is set for your directory
------------------------------------------------------------

I thought "AllowOverride All" was defined in the .htaccess ?

the .htacess is generated with the following content:

------------------------------------------------------------------

## SILVERSTRIPE START ###
<Files *.ss>
Order deny,allow
Deny from all
Allow from 127.0.0.1
</Files>

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /

RewriteCond %{REQUEST_URI} !(\.gif$)|(\.jpg$)|(\.png$)|(\.css$)|(\.js$)|(\.php$)

RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]
</IfModule>
### SILVERSTRIPE END ###

------------------------------------------------------------------

I never had this kind of errors.... so I don't really knowwhere to look....

any tips will be highly appreciated

cheers

Avatar
arthurdent

Community Member, 176 Posts

27 June 2013 at 3:30pm

Hi jujudeellago, did you get to the bottom of this? I find myself in the same situation!!

Avatar
Benwitz

Community Member, 7 Posts

19 July 2013 at 4:14am

The following may just be a warning, sometimes a warning in error as mod_rewrite is active. If you get this when installing try accessing your root page directly "www.mysite.com" and chances are your install was successful regardless of the warning.

"Friendly URLs are not working. This is most likely because mod_rewrite isn't configured correctly on your site. Please check the following things in your Apache configuration; you may need to get your web host or server administrator to do this for you: "

* mod_rewrite is enabled
* AllowOverride All is set for your directory