Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

no access to admin


Go to End
Reply

9 Posts   3451 Views

Avatar
marcink

23 June 2009 at 5:24am Community Member, 89 Posts

hi,

i just downloaded the new ss 2.3.2 and installed it without problems. but when i tried to go to admin, i got an error after login:

[User Error] Couldn't run query: SELECT Distinct Locale FROM SiteTree GROUP BY Locale Unknown column 'Locale' in 'field list'
GET /admin/

Line 400 in D:\_projekte\bartoszkolonko\www\sapphire\core\model\MySQLDatabase.php

for the full error see attached file

Attached Files
Avatar
Sam

23 June 2009 at 7:57pm Administrator, 685 Posts

Assuming your site is at http://www.example.com/, visit http://www.example.com/dev/build and then try again.

Avatar
marcink

24 June 2009 at 4:54am Community Member, 89 Posts

hi,

i did, there wasnt any errors, but again when trying to login to admin:

Website Error
There has been an error

The website server has not been able to respond to your request.

nothing more...

but i can still surf the site without login.

Avatar
Nivanka

24 June 2009 at 5:29pm Community Member, 395 Posts

did you added any custom page types?

Avatar
marcink

25 June 2009 at 3:32am Community Member, 89 Posts

no, its a fresh install. original template.

Avatar
Nivanka

25 June 2009 at 4:03pm Community Member, 395 Posts

Seems like your database is not populated properly, can you run a /dev/build and try again? Also check whether the site tree table is crashed, but I think better to run a dev/build first.

Avatar
BarkingDave

27 June 2009 at 2:42am Community Member, 1 Post

I have the same issue.

Tried the db/build and dev/build?flush with no luck. Just seems to point me to log in each time. And then I can't!

I found the following in the error log which points to a permissions issue I think!

PHP Warning: session_start() [<a href='function.session-start'>function.session-start</a>]: open(/var/lib/php/session/sess_sldvr8l7oedcburrkm22mr03h6, O_RDWR) failed: Permission denied (13) in /services/web/website/2.3.2/install.php on line 20
[Fri Jun 26 12:13:38 2009] [error] [client XX.XX.XX.XX] PHP Warning: Unknown: open(/var/lib/php/session/sess_sldvr8l7oedcburrkm22mr03h6, O_RDWR) failed: Permission denied (13) in Unknown on line 0

Avatar
hive.net.au

27 June 2009 at 6:17pm (Last edited: 12 October 2009 5:25pm), Community Member, 40 Posts

I had the same problem when i was trying a fresh install, after deleting temp files (your service provider may have to do this ) I was back in business.

Create a silverstripe-cache folder in the root of the site with server write permissions and you should be in business.

Go to Top