Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Installing SilverStripe on Xampp


Reply


3 Posts   3990 Views

Avatar
jackinthebox

Community Member, 1 Post

8 July 2009 at 3:05am

I love SS2, it is by far the best opensource CMS I've come across. I have a problem I hope someone here can help with. An ex-colleague installed Silverstripe and modded it to form the basis of our website. I want to be able to run a duplicate of this site on my laptop so I can experiment with some changes we are thinking of implementing. I have installed xampp, and both php and mysql work fine, and I have also installed the raw silverstripe and that works fine too.

The problem I have, is that I'm a virtual beginner when it comes to MySQL. So I have a copy of the file-tree/directories containing all of our site details, and I also have "mydatabase.sql" but I don't know how to make them work on my laptop!

The normal clean SS2 runs fine in

C:\xampp\htdocs\silverlight

but when I replace that with

C:\xampp\htdocs\silverlightmywebsite

I just get a list of files and folders in the directory, and then when I click on them, I get "object not found".

I expect I'm missing something blindingly obvious, but it's been a few years since I did any serious web dev and I was hoping someone here might take pity on me and point me in the right direction!

Any ideas? Thanks,

Jack

Avatar
Fuzz10

Community Member, 787 Posts

15 July 2009 at 7:28pm

Welcome to Silverstripe , good choice !

- Make sure to load your database dump. (Easy way of doing this is by installing PHPMyAdmin or DBTools).
- Make sure your _config.php contains the correct settings (project-name , database URL , username / password etc.)

Good luck !

Avatar
WorkingSolution

Community Member, 18 Posts

16 July 2009 at 1:54am

Edited: 16/07/2009 1:54am

=>C:\xampp\htdocs\silverlightmywebsite
was the path on Xampp right?

look in:
mysite/_config.php for this:

#code
$databaseConfig = array(
   "type" => "MySQLDatabase",
   "server" => "localhost",
   "username" => "YOUR_USERNAME",
   "password" => "YOUR_PASSWORD",
   "database" => "YOURTABLE_NAME",
);
/*here are some comments in original*/

Director::set_dev_servers(array(
   'localhost',
   '127.0.0.1',
));
#/code

try then:
http://localhost/silverlightmywebsite/dev/build/?flush=1

then it will work ( I think)