Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Installing on Wamp Server - XML Parsing Error: junk after document element


Reply


4 Posts   3866 Views

Avatar
chrisco_7

Community Member, 5 Posts

3 August 2009 at 2:30pm

I've just set up my Wamp Server and followed the install procedures to get SilverStripe up and running, when i got this error:

XML Parsing Error: junk after document element
Location: http://localhost:3000/SilverStripe-v2.3.2/home/successfullyinstalled?flush=1
Line Number 2, Column 1:

<b>Deprecated</b>: Function ereg_replace() is deprecated in <b>C:\wamp\www\SilverStripe-v2.3.2\sapphire\core\ManifestBuilder.php</b> on line <b>257</b><br />
^

I've had a bit of a look through the forums and couldn't find much. Any suggestions?

Avatar
Willr

Forum Moderator, 5513 Posts

3 August 2009 at 6:03pm

Are you using PHP5.3? You could try turn off notices by adding this to your _config - if(defined('E_DEPRECATED')) error_reporting(E_ALL ^ E_DEPRECATED);

Avatar
chrisco_7

Community Member, 5 Posts

3 August 2009 at 6:36pm

Thanks willr.

I tried going back in the browser and re-installing on a couple of occassions which seemed to get me past that problem, but I'd done nothing to fix it for any future occurances. Hopefully by dropping that code in it will sort it out.

I am using PHP 5.3 too. I'm running it on a local server through wamp, and it was the default. Is this wrong? What's should I be using?

Sorry for my ignorance - fresh to PHP and CMS.

Avatar
Willr

Forum Moderator, 5513 Posts

3 August 2009 at 7:04pm

I am using PHP 5.3 too. I'm running it on a local server through wamp, and it was the default. Is this wrong? What's should I be using?

Wow I am surprised WAMP updated so quickly - PHP5.3 is pretty new. Only released a couple weeks back. In this version they have deprecated several functions (which ss uses) so that is why you are seeing deprecated warnings.

SilverStripe 2.3.3 which was released a couple hours ago has some fixes for 5.3 notices which should make this less of an issue.