Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Install of SilverStripe 2.3.3 won't work


Reply

3 Posts   2086 Views

Avatar
websage

10 September 2009 at 5:13am Community Member, 6 Posts

Hi, I am in need of help or if nobody can give help then I hope it's being considered as a bug report.

I tried to install SS 2.3.3 on my Strato VServer. I already have a working installation of SS 2.3.2 on
the same server. And I am operating another with SS 2.3.2 on another Hosting.
However, I didn't manage to get the latest release working.

The install sheet shows ok on every subject. Once I click install I it redirects me to the install
status screen informing me it will take round 30 seconds. Well, I have waited for 5 minutes. No reaction.

I can't access index.php afterwards, nor does the install.php page show up correctly. Meaning all
variables are output by print_r() as it seems.

I tried to repeat the installation with a completely new upload. Same thing.
After working on this for 3 hours I lost my patience and used another CMS.

I think the SS community should consider to enforce testing before releasing a new
client too quickly.

If anyone has had the same issues and managed to get it working I would be happy to exchange
knowledge.

Regards

Frank

Avatar
WorkingSolution

10 September 2009 at 5:59am (Last edited: 10 September 2009 6:11am), Community Member, 18 Posts

Set the .htacess file on chmod 777 while installation and it will work.

But your webhoster has often low RAM/bandwith on vserver (shared hosts). Had a lot of trouble with while using:
- many read/write processes to mysql
- frequented websites
- gameservers
- some people report a lot of perfomance-problems using wordpress
- myself had probs some customers webspace on same hoster using smarty with cache on(yes - you config a solutions for more performance and get minor)

Maybe it will help ( on other cms systems too) to limit RAM (ini_set('memory_limit','32M') and high up the server-timeout.
Your hoster tells in advertising X-Bandwith, but don't tell you that the bandwith ist shared between a lot of vservers.

So the 2.3.3 version works proper on 1und1, server4you, hetzner and so on ( I think u are from germany when using strato).

Avatar
websage

11 September 2009 at 9:52am Community Member, 6 Posts

Hi WorkingSolution,

Thanks for your reply.

- I had set file permissions to 777 (SS install-script also reported everything with green color)
- I changed to a bigger VServer with 1GB guaranteed RAM, it's still only site I am operating on this server, with almost no traffic
so I don't think it maybe the problem.
- about the Gameserver ( I would not even dare to put this on a Vserver ;-) )
- RAM limit shouldn't be an issue as the Server guarantees 1 GB

I will have another look at the logs.

Thanks.