Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Problem with either Mod_rewrite or AllowOverride


Reply

3 Posts   3049 Views

Avatar
ITMonkey

13 September 2009 at 4:10am (Last edited: 15 September 2009 3:45am), Community Member, 6 Posts

Hi, when I try to install ss from install.php the initial system check shows this:

File permissionsDoes the webserver know where files are stored?   OK (/srv/www/)
mysite/ folder exists   OK
sapphire/ folder exists   OK
cms/ folder exists   OK
jsparty/ folder exists   OK
Is the .htaccess file writeable?   OK
Is the mysite/_config.php file writeable?   OK
Is the assets/ folder writeable?   OK
Is the temporary folder writeable?   OK

Webserver ConfigurationServer software   OK (Apache/2.2.10 (Linux/SUSE) Server at localhost Port 80)
mod_rewrite enabled   OK

But when I install it shows this error:

Friendly URLs are not working. This is most likely because mod_rewrite isn't configuredcorrectly on your site. Please check the following things in your Apache configuration; you may need to get your web host or server administrator to do this for you:
mod_rewrite is enabled
AllowOverride All is set for your directory

As you can see from above, it's openSuse (11.1) and Apache 2.2.10

In yast's http server configuration it has these two lines:
Option - Include; Value /etc/apache2/conf.d/*.conf
Option - Include; Value /etc/apache2/conf.d/apache2-manual?conf

I've edited default-server.conf, which shows the Directory as /srv/www/htdocs (Which is, indeed, where SS is stored) and changed the AllowOverride None line to AllowOverride All, saved, restarted Apache and... it's the same.

So, I've tried also editing /etc/apache2/conf.d/apache2-manual.conf, which now has:

<Directory "/srv/www/htdocs">
Options Indexes
AllowOverride All
Order allow,deny
Allow from all

(Previously Directory pointed to a manual directory)

and I also edited /etc/apache2/httpd.conf

# forbid access to the entire filesystem by default
<Directory "/srv/www/htdocs">
Options None
AllowOverride All
Order deny,allow
Deny from all
</Directory>

In which it was previously <Directory />

And in both of those files I have changed None to All

I have restarted apache after the changes and it doesn't work so I am now well and truly stuck, what am I missing?

Thanks

Avatar
ITMonkey

15 September 2009 at 4:04am Community Member, 6 Posts

By the way, SilverStripe HAS created some content in .htaccess

Avatar
ITMonkey

19 September 2009 at 1:51am (Last edited: 23 September 2009 2:12am), Community Member, 6 Posts

It was user error, extracting files into the wrong directory - sorry!