Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

New installation; Upload Images, Insert image, edit image don't work as expected


Reply

2 Posts   2189 Views

Avatar
REC

15 September 2009 at 6:57am Community Member, 4 Posts

There are three problems:

1. Upload Image only uploads some .png images. I haven't tried other file types. Don't see differences, other than size in the png images I tried to upload.

2. If I use the edit image box, accessed from right clicking on the image, I can't add a boarder or space. It notifies me that it was edited successfully when I click "save & publish" but it doesn't show in the published site.

3. If I click on "Insert Image" while logged on from the computer on which SilverStripe is installed, I get a "Detailed Error 500.0" message. If I click on "Insert Image" while logged on from a remote computer, everything is OK.

Here is the message for problem 3:
HTTP Error 500.0 - Warning: "Parameter 1 to Hierarchy::loadDescendantIDListInto() expected to be a reference, value given" at line 525 of C:\inetpub\wwwroot\MyXSite\sapphire\core\Object.php
The page cannot be displayed because an internal server error has occurred.

Detailed Error Information
Module: FastCgiModule
Notification: ExecuteRequestHandler
Handler: PHP via FastCGI
Error Code 0x00000000

Requested URL: http://localhost:80/myxsite/sapphire/main.php?
url=admin/EditorToolbar/ImageForm&action_callfieldmethod=1&fieldName=Image&ajax=1&SecurityID=8617&methodName=getimages&folderID=6&searchText=undefined&SecurityID=8617&cacheKillerDate=1253039578696&cacheKillerRand=9303

Physical Path: C:\inetpub\wwwroot\myxsite\sapphire\main.php
Logon Method: Anonymous
Logon User: Anonymous

I installed on IIS 7.5, MySQL 5.1.38, PHP 5.3.0
Any ideas?
Thanks

Avatar
Entar

24 September 2009 at 8:24am (Last edited: 24 September 2009 8:32am), Community Member, 19 Posts

have this problem too on php 5.3.0 but no error on php 5.2.4! devs?