Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Problem installing with Windows Web platform


Reply

6 Posts   2803 Views

Avatar
davout

25 October 2009 at 7:18am Community Member, 2 Posts

I've tried installing your product onto my Vista laptop using the Windows Web Platform but when I try to open the start page I get the error...

---oOo---

HTTP Error 500.19 - Internal Server Error
The requested page cannot be accessed because the related configuration data for the page is invalid.

Detailed Error Information
Module IIS Web Core
Notification Unknown
Handler Not yet determined
Error Code 0x80070003
Config Error Cannot read configuration file
Config File \\?\C:\Users\Ian\AppData\Local\silverstripe\web.config
Requested URL http://localhost:80/test01/index.php
Physical Path
Logon Method Not yet determined
Logon User Not yet determined

---oOo---

Also when I run the install process its not clear what folder should be chosen for the physical location.

Avatar
baba-papa

28 October 2009 at 9:37am Community Member, 279 Posts

By not using microsoft products you get rid of most of your problems.

Avatar
davout

30 October 2009 at 7:36am Community Member, 2 Posts

That sort of reply doesn't help anybody.

The vendor advertises an install using a Windows web based install, I try to use it, it fails, I place a support question. Fairly straightforward really.

As I've not had the courtesy of a meaningful answer I've dropped my plan to evaluate this product and will look at 'CMS Made Easy' instead.

Avatar
lord_Lethris

30 October 2009 at 9:09am Community Member, 3 Posts

FanBoys really need to learn to hold there tongue.

Not everyone's Hosts runs Linux/Apachie.
And there are some elements of IIS that some companies use that Apachie doesnt have - I.E. OWA for example...

Avatar
youngmug

30 October 2009 at 4:20pm Community Member, 19 Posts

Not too familiar with the "Web Platform", but if it uses IIS, make sure the IUSR_machinename account has read/write access to your Silverstripe folder and all items within.

Avatar
Thobor

14 May 2010 at 7:59am Community Member, 1 Post

Thank you for the comment about permissions.

I fixed the exact problem by typing my windows username and password into the Basic settings of IIS.
Then everything worked :)

Attached Files