Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Migrating a Site to Silverstripe /

What you need to know when migrating your existing site to SilverStripe.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Need help Importing from Wordpress


Reply


4 Posts   1730 Views

Avatar
Rhyous

Community Member, 7 Posts

4 September 2010 at 6:43pm

Edited: 04/09/2010 6:44pm

Hey all,

I installed SilverStripe and have chosen to eventually move to it. See [url=http://rhyous.com/2010/09/03/drupal-joomla-wordpress-silverstripe-or-other-which-content-management-system-cms-is-best-for-a-bsd-user/]this post[/url].

I read about Wordpress Importer and installed it from SVN.
svn checkout http://svn.silverstripe.com/open/modules/wordpressimport/trunk

I exported my Wordpress site to xml.

I then logged into the admin page and started an import.

It says it is processing, but really, two hours later, could it really be processing still? It looks hung up to me or like it is not doing anything.

Any ideas would be great!

Any links to documentation would be great. There Readme had a link but when I went there, it says the doc doesn't exist.

Avatar
Willr

Forum Moderator, 5513 Posts

4 September 2010 at 7:19pm

That extension from the looks of it hasn't been updated for a couple of years so its likely that it hasn't been keep up to date with the Wordpress model or SilverStripe.

You might want to email the module owner (its in the readme file) to see what the best way to go forward is. You don't get any errors to your PHP error log when running it do you?

Avatar
Rhyous

Community Member, 7 Posts

5 September 2010 at 4:29am

Thanks for the help.

FreeBSD with Apache and PHP, PHP dumps its logs to /etc/httpd-error.log by default.

It does cause an error, but just one single line. Here is the error:

[Sat Sep 04 10:14:59 2010] [error] [client 192.168.0.49] PHP Fatal error: Call to undefined method SimpleXMLElement::setValue() in /usr/local/www/apache22/data/silverstripe/sapphire/core/model/DataObject.php on line 1014, referer: http://192.168.0.42/silverstripe/WpImporter_Controller/index/15

This is a starting point.

Avatar
Willr

Forum Moderator, 5513 Posts

5 September 2010 at 9:31am

setValue() doesn't appear in the API (http://www.php.net/manual/en/class.simplexmlelement.php) I guess it should use addValue() or addAttribute rather than set