Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Migrating a Site to Silverstripe /

What you need to know when migrating your existing site to SilverStripe.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Migrating CMSMS Site to Silverstripe


Reply


4 Posts   1188 Views

Avatar
drawingcloudsintheair

Community Member, 3 Posts

6 January 2013 at 5:35am

Hello,

I'm migrating an old site from CMS Made Simple to Silverstripe. I installed SS on my local machine using MAMP.

I found some storage behavior. When I try to create a template, and put the html code from the old site in it, and restart mamp and the try to open the admin interface, I get a blank page that contains only the footer and no way to login.

If I remove the html code from the old site from the template, everything works normal again.

Could anybody help me? I'm new to Silverstripe. Many thanks!

This is what my Page.ss template looks like:

...
<body>
$Content

<% include Footer %>

</td>
</tr>
</table>

</body>
<script src="http://www.google-analytics.com/urchin.js" type="text/javascript">
</script>
<script type="text/javascript">
_uacct = "UA-194517-1";
urchinTracker();
</script>
</html>

Avatar
Webdoc

Community Member, 332 Posts

6 January 2013 at 9:49am

Edited: 06/01/2013 9:50am

did u flush using ?flush=all after the adress

Avatar
sonet

Community Member, 33 Posts

6 January 2013 at 7:27pm

Do you have $Form variable in your template? This is where the login form is rendered.

Avatar
drawingcloudsintheair

Community Member, 3 Posts

6 January 2013 at 10:52pm

@Webdoc
Yes. No change.

@sonet
Nope. Thanks for the hint. It sort of works but when I try to login, the form redirects me to the live site instead of the one on my local mamp installation. How can I change that?

Thanks!