Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Migrating a Site to Silverstripe /

What you need to know when migrating your existing site to SilverStripe.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Internal Server Error issue


Reply


16 Posts   3678 Views

Avatar
Heike-san

Community Member, 52 Posts

20 October 2009 at 9:06pm

It seems like the folder is read only and that the .htaccess is disappearing from the site tree each time a upload it.
I am going to make the proper changes and I will let you know!!

Avatar
Heike-san

Community Member, 52 Posts

20 October 2009 at 10:53pm

So I have checked:
.htaccess is present remotly
permissions on the files are OK
remove the DirectorySlash and <Files *.ss> directives : Done
mod_rewrite is properly installed: Dunno how to check that but it works locaaly so mod_rewrite should be installed

It is still not working!!

Avatar
banal

Community Member, 901 Posts

20 October 2009 at 11:54pm

A working local installation doesn't necessarily work on a remote machine. Are you using the onedoor directory locally and on the remote machine?

Avatar
Heike-san

Community Member, 52 Posts

21 October 2009 at 2:09am

Yeah I am using it on both but I finally work it out, mod_rewrite was the issue I needed to change the SERVER_SIGNATURE to SERVER_SOFTWARE in install.php and remove RewriteBase from the .htaccess.

Avatar
Heike-san

Community Member, 52 Posts

21 October 2009 at 12:33pm

In fact,it is still not working, something is causing major bugs on the cms side.
Though I granted all the privileges on the .htaccess files I whenever i try to edit a page in the cms i got a blank or warning/error page!!

Avatar
OwenW

Community Member, 45 Posts

21 October 2009 at 8:34pm

Heike-san,

Out of interest, What OS are you running this under?

With the error page that you are getting returned, Is it from Silverstripe or from the webserver itself?

Avatar
Heike-san

Community Member, 52 Posts

21 October 2009 at 10:06pm

The OS is Windows Xp or Vista (depending that I am working from home or at the office).
And the error seems to come from the server.
Although I think I've settled the matter by using the content of previous websites cms and sapphire folder.
Turns out it works okay, but I haven't fully tested the website though so not 100% sure.

Avatar
vstrazz

Community Member, 63 Posts

24 October 2009 at 7:02am

What version of PHP are you running?