Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Releases and Announcements /

Latest news about the SilverStripe software.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

SilverStripe 2.4.0-alpha1 to stable?


Reply


5 Posts   1370 Views

Avatar
swaiba

Forum Moderator, 1799 Posts

29 January 2010 at 10:40pm

Hi,

Do you have an idea when you might be officially releasing a stable 2.4 please?

Barry

Avatar
Taffy

Community Member, 119 Posts

29 January 2010 at 11:03pm

http://open.silverstripe.org/roadmap

Avatar
swaiba

Forum Moderator, 1799 Posts

9 March 2010 at 10:41pm

Taffy thank you very much for the link, I have been watching this over the last couple of months. Unfortunately it still doesn't give me an idea when I might expect to be able to rely on the 2.4 platform. This is critically important as Model Admin seems very unstable before 2.4... in the time I have left for my project I need to either know I can use 2.4 or make 2.3.6 ModelAdmin work without issue

Avatar
Willr

Forum Moderator, 5513 Posts

10 March 2010 at 5:27pm

Hmm funny I had backported some of the bugfixes for ModelAdmin to 2.3 so if you could clarify what major bugs you are encountering that would be good. Then at least branches/2.3 is stable.

Next beta / rc release is due very soon. Then I guess it will be a few weeks, maybe up to a month after that next release before an official stable. Though we have been running 2.4 for a while so you might be looking to upgrade to the next beta / rc since the API should have been locked down by then.

Avatar
swaiba

Forum Moderator, 1799 Posts

11 March 2010 at 12:46am

Edited: 11/03/2010 12:50am

Hi Will,

Thanks for your response, I have spent quite a while trying to workout what is going on without any results...

There were problems with the export to csv, but I couldn't reproduce that right away (maybe it was in 2.3.5 and fixed now?).

the issue I see over and again relates to validation, I have prepared a full description of this and attached it to this post... basically when a field fails validation the screen resets itself to the welcome screen instead of leaving you on the record edit screen with he validation error feedback... this is within 2.3.6 and across browsers (ie/chrome/ff)

Barry

Attached Files