Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Releases and Announcements /

Latest news about the SilverStripe software.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

A new eCommerce module for SS: SilverCart released


Go to End
Reply


12 Posts   4442 Views

Avatar
baba-papa

Community Member, 279 Posts

4 March 2011 at 6:16am

We just proudly released our eCommerce module for SilverStripe called [url=http://www.silvercart.org]SilverCart[/url]. We appreciate downloads and feedback.

Avatar
joelg

Community Member, 129 Posts

7 March 2011 at 12:08pm

Looks really great. Looking forward to trying this.

I'm missing a backend demo-site of this, where can i find one?

Avatar
baba-papa

Community Member, 279 Posts

8 March 2011 at 12:09am

Hi Joel,
we do not have a backend demo yet. We are about to install one, thanks for Your request.

Avatar
baba-papa

Community Member, 279 Posts

6 April 2011 at 8:03pm

We did some major changes to our module. [url=http://www.silvercart.org/documentation/]The installation[/url] is now easier and has less steps. Furthermore I made a little [url=http://www.youtube.com/watch?v=lDclAfELK98&feature=player_embedded]installation screencast[/url].

Avatar
SSadmin

Community Member, 90 Posts

13 April 2011 at 11:24am

i have tried to install the silvercart on my test bed.
But seems not that smoothly.
I am running silverstripe 2.4.5 and followed the work-flow.

first.
SiteTree::set_create_default_pages(false);

causing :
Fatal error: Call to undefined method SiteTree::set_create_default_pages() in C:\wamp\www\silvercart\silvercart\_config.php on line 38

Then if i comment that line:
another error occurs:

Fatal error: Uncaught exception 'ReflectionException' with message 'Class SiteConfig does not exist' in C:\wamp\www\silvercart\sapphire\core\Object.php

Well, not sure whats the silverstripe version required for silvercart.. wonder the core APIs have been updated by silverstripe?!

Class SiteConfig does not exist'

Avatar
Ramon

Community Member, 14 Posts

13 April 2011 at 7:47pm

Hi SSadmin,

thank you for testing SilverCart.

Are you sure you had a running SilverStripe installation with the required modules before setting up SilverCart?

It is a bit strange that a plain static method call on a SilverStripe core class does not work on your box.

Can you please check if C:\wamp\www\silvercart\sapphire\core\model\SiteTree.php is present and readable on your webserver?
Is the method set_create_default_pages() present in file C:\wamp\www\silvercart\sapphire\core\model\SiteTree.php ?
Can you please check if C:\wamp\www\silvercart\sapphire\core\model\SiteConfig.php is present and readable on your webserver?
Can you please post the related entries from your logfiles (e.g. php.log)

I am not sure if this is really related to SilverCart.

Maybe you want to run /dev/build/?flush=all and see if there is any useful output or errors.

Cheers
Ramon

PS: I hope we don't hijack the announcement thread here with troubleshooting :-)

Avatar
baba-papa

Community Member, 279 Posts

23 April 2011 at 8:38pm

A few days ago we leseased SilverCart 1.0 which brings a lot of enhancements, new features and bugfixes. Read more about the release on [url=http://www.silvercart.org/blog/silvercart-1-0-rc1-released/]SilverCart´s website[/url].

Avatar
baba-papa

Community Member, 279 Posts

25 April 2011 at 9:16pm

Edited: 27/04/2011 9:48pm

@joelg: We do have a [url=http://demo.silvercart.org/]demo shop[/url] now. Find more information on [url=http://www.silvercart.org/forum/announcements/show/79#post79]SilverCart's website[/url].

Go to Top