Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Releases and Announcements /

Latest news about the SilverStripe software.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

SilverStripe 2.3.2-rc1


Reply


27 Posts   7102 Views

Avatar
MarijnKampf

Community Member, 164 Posts

29 May 2009 at 4:27am

I don't know whether this is a bug, or me just being blond. Hence my post here rather than posting a bug report as it concerns SilverStripe 2.3.2-rc1.

I've created a multi language site - Dutch and English. I've created translations of the standard pages based on the Dutch originals including the contact pages. On the Dutch home page (Original language) I can create a link using the side panel Link to > Page on the site > (Choose) pull down list to the contact page. In the English site however, I only see the Dutch pages in the pulldownlist. I would expect to see the English pages there rather than the Dutch (or at least both English and Dutch pages). Did I miss/forget something in the setup or is this a bug?

Avatar
Juanitou

Community Member, 323 Posts

29 May 2009 at 4:36am

This is a bug: [url]http://open.silverstripe.com/ticket/3995[/url]

Manual linking so…

Avatar
Ingo

Forum Moderator, 801 Posts

29 May 2009 at 11:16am

> In the English site however, I only see the Dutch pages in the pulldownlist. I would expect to see the English pages there rather than the Dutch (or at least both English and Dutch pages). Did I miss/forget something in the setup or is this a bug?

Thats an "outstanding feature" that we unfortunately won't get done for this release: http://open.silverstripe.com/ticket/3503

@Juanitou: #3995 should be fixed, thanks for following up on it!

Avatar
Juanitou

Community Member, 323 Posts

29 May 2009 at 8:20pm

Hi!

I'm certainly being blunt, but using the code of r78118 for LeftAndMain_Left.js and that of r76608 for CMSMain_left.js the translated sub-tree still does not work. I have really to spend sometime learning how to use SVN… and JavaScript!

I can live without this feature: at least I know how to manually add a link!

Anyway, 2.3.2 looks very promising, congrats!

Avatar
MarijnKampf

Community Member, 164 Posts

30 May 2009 at 1:21am

I don't want to go reopening any closed/invalid bugs reports but relating to http://open.silverstripe.com/ticket/4159

Replying to [comment:2 sharvey]:
> The main issue is that all tags generated by sapphire are generated for XHTML.

If XHTML is generated by default wouldn't the closing /> be required for the alternate link? At the moment it's not there in the code. Adding it fixes the issue. Or am I missing something here?

Avatar
Juanitou

Community Member, 323 Posts

30 May 2009 at 1:28am

At least you're not alone: I think I'm missing something too! :D

Avatar
HansR

Community Member, 140 Posts

30 May 2009 at 4:32pm

I just had the same problem as slang, but with version 2.3.2-rc2. Gerwout's hack worked, but I'd prefer it if an official solution were found.

If it helps, the server that my website is running on is IIS 5.

Hans

Avatar
Ingo

Forum Moderator, 801 Posts

2 June 2009 at 8:35am

Damn, missed merge from trunk to branches/2.3 - should be fixed now: http://open.silverstripe.com/changeset/78167#file2.
The fix will show up in our next RC for 2.3.2