Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Template Questions

changing 'your site name' in a theme ruins whole site


Reply

5 Posts   1186 Views

Avatar
chukler

3 April 2010 at 1:41am Community Member, 4 Posts

Hi, I'm really a novice web designer so please forgive me if I use the wrong terms or whatever! I've been working on a site for a friend (re-building it in Silverstripe) and have been through about 6 themes (including Blackcandy), as I've been able to get everything sorted, including the footer text changes, but whenever I try to change the site name and/or tag line in Page.ss, it overrides almost all structure/layout whatever (ie. there's no fixed width, navigation, page layout etc etc!). I haven't been able to change any of it back either. I have a MacBook and use Silverstripe 2.3.7, don't know if any of that makes a difference?
Cheers...

Avatar
Juanitou

3 April 2010 at 2:34am Community Member, 323 Posts

Hi!

Could you post the lines in Page.ss that work (re-install one of those themes you talked about) and the modifications that break the layout?

Avatar
chukler

3 April 2010 at 3:08am Community Member, 4 Posts

$MetaTags
Your Site Name
your site's tagline here

$Layout

I open it in TextEdit (the only option on my Mac), I tried to convert it to plain text but then I couldn't save it as an .ss file. I want to have Paw Prints Pet Training™ in place of Your Site Name, and Dog training in Perth, Western Australia in place of your site's tagline here.

Avatar
Juanitou

4 April 2010 at 2:14am Community Member, 323 Posts

There’s a bunch of errors in this file.

First, I doubt it could work if it is really called Page7.ss (or maybe your page type is called Page7 and is defined in a Page7.php file?).

Have you a Layout/Page7.ss template for obtaining the content of the page? Also, $Layout will certainly break if you include it in <p> tags since it includes its own HTML.

The same thing for $MetaTags, that have to be in the <head> section.

I think you should follow a tutorial on HTML and on SS templates before going further. Have you followed the SS tutorials? There’s a lot to learn there.

Hope it helps,
Juan

Avatar
chukler

4 April 2010 at 2:23am Community Member, 4 Posts

Sorry I'd attached the wrong document, not sure where the Page7.ss came from!

It's all sorted now though - finally found an archive (http://www.silverstripe.org/archive/show/135936) that worked, it was because TextEdit won't recognise that file. It recognised all other .ss files for some reason. I downloaded Smultron and it worked beautifully!

Thanks for your help!