Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Template Questions /

Generated with the default ContentController.ss template


Go to End
Reply


17 Posts   7824 Views

Avatar
mirkosassetti

Community Member, 20 Posts

18 June 2010 at 9:33pm

This is the message i receive when loading a new page type in 2.4.
More details:
i have a published site made with silverstripe 2.4 that works fine. This site was migrated from a developing server some weeks ago.
Now i create a new page type, Home, extended by Page, for customizing the Home page with an image.
dev/build ok, changed page type in behavior ok, add an image ok, i go to the home page and i see it with my new image. Well.
Some hours later the customer say me that the home page is blank with only the contents and the "Generated with the default ContentController.ss template" message at the end.
I go to the home page and verify the problem.
I remember, i don't do the ?flush=1 on the page!
I do the flush and i see the correct page, but when i remove the ?flush=1 from URL i'll see the blank page again!
Tried to empty the browser cache and tried with various browsers.
What happen?
It seems that can't write the cache or something similar.
For now i revert back the page type to Page in behavior and all works fine.
Any idea?

Thanks!

Avatar
Willr

Forum Moderator, 5513 Posts

18 June 2010 at 11:16pm

Edited: 18/06/2010 11:16pm

Strange, perhaps try a ?flush=all rather than a ?flush=1. Other thing you can do is make a 'silverstripe-cache' folder in your site root and make sure you can read / write to that new folder.

Avatar
mirkosassetti

Community Member, 20 Posts

19 June 2010 at 4:38am

The ?flush=all dosn't solve the problem, but the creation of the 'silverstripe-cache' do it.
Thanks a lot!

Avatar
te_chris

Community Member, 24 Posts

21 July 2010 at 9:06pm

Edited: 21/07/2010 9:06pm

Hey,

I've had the same problem but neither solution has worked. Any ideas?

Avatar
mirkosassetti

Community Member, 20 Posts

21 July 2010 at 9:59pm

That's strange.
Have you tried to create the "silverstripe-cache" folder and next a "flush=all". This always work for me.

Avatar
te_chris

Community Member, 24 Posts

22 July 2010 at 12:40am

yeah done that. no dice

Avatar
Martijn

Community Member, 271 Posts

22 July 2010 at 7:09am

Maybe stupid to mention, but I had this message when I forgot to add a correct Controller class with the extended Page class.

You do have class HomePage_Controller extends Page_Controller{} in your HomePage extends Page class?

Avatar
te_chris

Community Member, 24 Posts

22 July 2010 at 9:45am

argh. yeah of course. that was it. I refactored a lot of my models and thus had to change some page types and messed up the controller. Thanks!!

Go to Top