Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Template Questions /

Themeless Admin Error


Reply


2 Posts   765 Views

Avatar
Mr V Dot

Community Member, 8 Posts

4 October 2010 at 9:34am

Edited: 04/10/2010 9:35am

Ok, so I realize this is a strange error, but it's plagued me on several different sites now, and I haven't found anyone else with this problem on the forums. If I am using a custom theme and have logged in as a user without CMS permissions (ie. regular site user), if I try to access the CMS, all I get is a white page with the usual error "I'm sorry, but you can't access that part of the CMS. If you want to log in as someone else, do so below", but with no form or any other rendering of the theme, that error is literally the only content returned (ie. not even any html if I view source). I've read through the various themes and compared them with blackcandy (which works just fine), and can't see any difference. Any suggestions on where I should look? Thanks, Alex

Edit. And yes, I do have "$Form" on my Layout/Page.ss files

Attached Files
Avatar
swaiba

Forum Moderator, 1799 Posts

4 October 2010 at 10:19am

I've always thourght that it was a tad unfriendly when you cannot access a part of the CMS. But to be fair it only happened when I'd truncate the members table or something else unexpected so I got used to going to security/logout manually at that point.

Anway, the message is set in function init() of cms\code\LeftAndMain.php and follwoing it's return type it look like it should be redirecting to the login form, with redirect back once login supplied.

Looks like a bug