Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Template Questions /

Trying to work with Tutorial.. problems :)


Reply


2 Posts   353 Views

Avatar
silus

Community Member, 2 Posts

7 January 2012 at 5:22am

HI everybody!

im new here, and i've build many websites with wordpress/joomla but its to much work and so, so after few weeks i've decided to use only this cms :) So, im building my first template and i try to go with the "Tutorial 1 - Building a Basic Site" (html and css finished already).

when creating new file in mysite/code HomdePage.php and flushing page localhost:63464?flush=1 i cant change the home page to the new template coz its not there. i've copied the code, made new file and flushed.. cant see it. any help?

och, and i'll be a pain in the ass for some time, but when i make my way into understending all the cms things i need i'll work with it :) so sorry, and thnak you for any reply and help that i can get :)

Avatar
martimiz

Forum Moderator, 1132 Posts

8 January 2012 at 8:20am

Hi Silus

when you create a new pagetype like HomePage.phh, the next thing you need to do is call

mydomain.com/dev/build/?flush=1

dev/build will update the database for the new pagetype and add HomePage to the list of Pagetypes SilverStripe recognizes.

You'll be using a simple ?flush=1 when you need to refresh the cache after you change things like for instance in your templates...