Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Themes

Discuss SilverStripe Themes.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

CSS not updating


Reply

4 Posts   797 Views

Avatar
Ryan Lawrence

16 February 2012 at 12:23am (Last edited: 16 February 2012 12:25am), Community Member, 8 Posts

Hi,
For some reason the CMS isn't updating when I upload a new layout.css. The New layout.css has uploaded correctly to the server and is showing what it should: http://majestictheatre.planetryan.co.uk/themes/Majestic2/css/layout.css (This version is the one I want) However my pages are pointing to an old version of the css.
When I look at my source code it points to: http://majestictheatre.planetryan.co.uk/themes/Majestic2/layout.css?m=1329304083

The only fix i have is to reinstall the whole CMS and I don't want to do that every time I want to update the layout.

Can anybody help?
Ryan

Avatar
Lexandclo

16 February 2012 at 12:38am Community Member, 34 Posts

Hi

what happens when you deleted this one

http://majestictheatre.planetryan.co.uk/themes/Majestic2/layout.css

SS will pick that style sheet first

Let me know

Darren

Avatar
martimiz

16 February 2012 at 1:13am Forum Moderator, 1091 Posts

Did you change the path to your new css in the page template? And most importantly - did you do a ?flush=1 afterwards?

Avatar
Ryan Lawrence

16 February 2012 at 6:29am Community Member, 8 Posts

Thank-you for you quick replies :) It turns out I didn't realise that I uploaded layout.css to majestic2/ by mistake, So i just deleted it and all sorted now. Thank-you Turnaround Guy and Martimiz.
Ryan :)