Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Themes

Discuss SilverStripe Themes.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

RC3: None of these templates can be found: Page.ss, ContentController.ss


Go to End
Reply

9 Posts   4993 Views

Avatar
parawing742

7 February 2009 at 10:21pm Community Member, 1 Post

I just downloaded and am trying to setup my theme into 2.3.0 RC3. However, I get this error for any themes other than blackcandy and tutorial.

None of these templates can be found: Page.ss, ContentController.ss

It's weird too as I can rename tutorial to a different name it won't work either. What could possibly be going wrong?

Avatar
ajshort

7 February 2009 at 11:08pm Community Member, 244 Posts

Try adding ?flush to your URL - this makes SilverStripe regenerate the themes cache.

Avatar
webdave

11 February 2009 at 9:31am Community Member, 2 Posts

Hello,

I have the same problem... I installed a few new themes and they doesnt work. Only the blackcandy theme works all other themes doesnt work. I tried to change the permissions of the themes folders like the folder blackcandy and also to add ?flush at my URL, but it doesnt works anyway.

Hope someone can help me?

Avatar
webdave

11 February 2009 at 10:18pm Community Member, 2 Posts

ok, i found the problem: I've renamed all my theme folders and I found that the theme folders with an "_" in the name doesn't work. When I renamed the folder and tried it again it works.

Avatar
stopandstare

19 February 2009 at 1:39am Community Member, 1 Post

i have this problem too..i've tried lots of different themes (even ones without a '_' in them like the previous post said?) and none of them are working..it just comes up with the 'fatal error' etc.
i don't know what i'm doing wrong! because i'm doing everything that it says to!

Avatar
_Vince

30 May 2009 at 8:55pm Community Member, 161 Posts

+1 for flushing the cache. :o)

Avatar
carnal

11 September 2009 at 6:01am Community Member, 19 Posts

Hi there,

i had the same problem, for me removing the '_' in my template name works!

Hartmut

Avatar
thany

29 January 2014 at 2:38am Community Member, 6 Posts

I too stumbled upon this topic when encountering this error.

Big phat -1 for cache that doesn't invalidate when it needs to! I fricking hate caches in development mode.

Go to Top